From ed514e7f9ecc557fdddf2e22f3ad372affc1999b Mon Sep 17 00:00:00 2001
From: Val Kulkov <val.kulkov@gmail.com>
Date: Thu, 20 Dec 2018 15:04:43 -0500
Subject: busybox: keep syslog.conf during sysupgrade

If a user finds that logd is too barebone for their needs and wishes
to have more control over syslog, the user presently has an option
to enable CONFIG_BUSYBOX_CONFIG_FEATURE_SYSLOG and configure syslog
with settings in /etc/syslog.conf.

Presently /etc/syslog.conf silently disappears on sysupgrade. This
patch prevents such unwanted behaviour if busybox syslog is enabled
via CONFIG_BUSYBOX_CONFIG_FEATURE_SYSLOG.

Signed-off-by: Val Kulkov <val.kulkov@gmail.com>
---
 package/utils/busybox/Makefile | 6 ++++++
 1 file changed, 6 insertions(+)

(limited to 'package')

diff --git a/package/utils/busybox/Makefile b/package/utils/busybox/Makefile
index 0eaec19938..dbc5dee62c 100644
--- a/package/utils/busybox/Makefile
+++ b/package/utils/busybox/Makefile
@@ -73,6 +73,12 @@ define Package/busybox/config
 	source "$(SOURCE)/Config.in"
 endef
 
+ifdef CONFIG_BUSYBOX_CONFIG_FEATURE_SYSLOG
+define Package/busybox/conffiles
+/etc/syslog.conf
+endef
+endif
+
 # don't create a version string containing the actual timestamp
 export KCONFIG_NOTIMESTAMP=1
 
-- 
cgit v1.2.3