From 6cd84c68386d614b4838346b8b16f0431bd07e3e Mon Sep 17 00:00:00 2001
From: Florian Fainelli <florian@openwrt.org>
Date: Mon, 2 Apr 2007 16:09:15 +0000
Subject: Use find -exec instead of xargs

SVN-Revision: 6837
---
 target/imagebuilder/Makefile | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

(limited to 'target/imagebuilder/Makefile')

diff --git a/target/imagebuilder/Makefile b/target/imagebuilder/Makefile
index 0cbbfa2835..3d830bbc2d 100644
--- a/target/imagebuilder/Makefile
+++ b/target/imagebuilder/Makefile
@@ -33,8 +33,8 @@ $(BIN_DIR)/$(IB_NAME).tar.bz2: clean
 	$(CP) $(TOPDIR)/target/linux/* $(IB_BUILD_DIR)/target/linux
 	rm -rf $(IB_BUILD_DIR)/target/linux/*/patches
 	-cp $(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)/* $(IB_BUILD_DIR)/build_$(ARCH)/linux-$(KERNEL)-$(BOARD) # don't copy subdirectories here
-	find $(IB_BUILD_DIR) -name .svn | xargs rm -rf 
-	find $(IB_BUILD_DIR) -name CVS | xargs rm -rf 
+	find $(IB_BUILD_DIR) -name .svn -exec rm -rf {} \;
+	find $(IB_BUILD_DIR) -name CVS -exec rm -rf  {} \;
 	(cd $(BUILD_DIR); \
 		tar cfj $@ $(IB_NAME); \
 	)
-- 
cgit v1.2.3