From 6b045c7dc690a2626248c925cb80cc1717987cc7 Mon Sep 17 00:00:00 2001
From: Andy Boyett <agb@openwrt.org>
Date: Tue, 29 Jul 2008 03:36:11 +0000
Subject: Generate gzipped package lists - Can be used by changing the src line
 in /etc/ipkg.conf to src/gz - Cannot be used by busybox ipkg

SVN-Revision: 11981
---
 target/imagebuilder/files/Makefile | 6 ++++--
 1 file changed, 4 insertions(+), 2 deletions(-)

(limited to 'target/imagebuilder/files')

diff --git a/target/imagebuilder/files/Makefile b/target/imagebuilder/files/Makefile
index aa5b97150d..27a6c94f9d 100644
--- a/target/imagebuilder/files/Makefile
+++ b/target/imagebuilder/files/Makefile
@@ -1,6 +1,6 @@
 # Makefile for OpenWrt
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -112,7 +112,9 @@ endif
 package_index: $(TOPDIR)/tmp/ipkg.conf FORCE
 	@echo
 	@echo Building package index...
-	(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages) >/dev/null 2>/dev/null
+	(cd $(PACKAGE_DIR); $(SCRIPT_DIR)/ipkg-make-index.sh . > Packages && \
+		gzip -9c Packages > Packages.gz \
+	) >/dev/null 2>/dev/null
 	$(IPKG) update
 
 package_install: FORCE
-- 
cgit v1.2.3