From cc68bd353edd4ba33e0ddc8fa6f5b96737750bfb Mon Sep 17 00:00:00 2001
From: Gabor Juhos <juhosg@openwrt.org>
Date: Fri, 21 Sep 2007 19:00:45 +0000
Subject: rename NAND driver

SVN-Revision: 8932
---
 .../linux/adm5120/patches-2.6.22/004-adm5120_nand.patch  | 16 ++++++++++------
 1 file changed, 10 insertions(+), 6 deletions(-)

(limited to 'target/linux/adm5120/patches-2.6.22/004-adm5120_nand.patch')

diff --git a/target/linux/adm5120/patches-2.6.22/004-adm5120_nand.patch b/target/linux/adm5120/patches-2.6.22/004-adm5120_nand.patch
index 79915e0281..5441fef415 100644
--- a/target/linux/adm5120/patches-2.6.22/004-adm5120_nand.patch
+++ b/target/linux/adm5120/patches-2.6.22/004-adm5120_nand.patch
@@ -2,15 +2,19 @@ Index: linux-2.6.22.1/drivers/mtd/nand/Kconfig
 ===================================================================
 --- linux-2.6.22.1.orig/drivers/mtd/nand/Kconfig
 +++ linux-2.6.22.1/drivers/mtd/nand/Kconfig
-@@ -81,6 +81,12 @@ config MTD_NAND_TS7250
+@@ -81,6 +81,16 @@ config MTD_NAND_TS7250
  	help
  	  Support for NAND flash on Technologic Systems TS-7250 platform.
  
-+config MTD_NAND_RB100
-+	tristate "NAND Flash device on RB100 board"
-+	depends on MTD_NAND
++config MTD_NAND_ADM5120
++	tristate "ADM5120 NAND support"
++	depends on MTD_NAND && MIPS_ADM5120
 +	help
-+	  Support for NAND flash on RB100 platform.
++	  This enables the driver for the ADM5120 SoC built-in
++	  NAND flash interface.
++
++	  No board specific support is done by this driver, each board
++	  must advertise a platform_device for the driver to attach.
 +
  config MTD_NAND_IDS
  	tristate
@@ -23,7 +27,7 @@ Index: linux-2.6.22.1/drivers/mtd/nand/Makefile
  obj-$(CONFIG_MTD_NAND_SPIA)		+= spia.o
  obj-$(CONFIG_MTD_NAND_AMS_DELTA)	+= ams-delta.o
  obj-$(CONFIG_MTD_NAND_TOTO)		+= toto.o
-+obj-$(CONFIG_MTD_NAND_RB100)		+= rbmipsnand.o
++obj-$(CONFIG_MTD_NAND_ADM5120)		+= adm5120-nand.o
  obj-$(CONFIG_MTD_NAND_AUTCPU12)		+= autcpu12.o
  obj-$(CONFIG_MTD_NAND_EDB7312)		+= edb7312.o
  obj-$(CONFIG_MTD_NAND_AU1550)		+= au1550nd.o
-- 
cgit v1.2.3