From 7cc3beff324d2418c261b59a25dcf180b56232de Mon Sep 17 00:00:00 2001
From: John Crispin <john@openwrt.org>
Date: Mon, 2 Nov 2015 10:17:15 +0000
Subject: ar71xx: Add support for wdr7500v3

The device is similar to Archer C7 v2, but with 8M of flash, and 6 external
antennas.  Reason for breaking the naming pattern is that sticker on the back
mentions "WDR7500" and has no mention of "Archer".

Signed-off-by: Srdjan Rosic <rosic@google.com>

SVN-Revision: 47344
---
 target/linux/ar71xx/image/Makefile | 9 ++++++++-
 1 file changed, 8 insertions(+), 1 deletion(-)

(limited to 'target/linux/ar71xx/image/Makefile')

diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index ddc0fc1b15..7bf2f278eb 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -372,7 +372,14 @@ define Device/archer-c7-v2
     DEVICE_PROFILE := ARCHERC7
     TPLINK_HWID := 0xc7000002
 endef
-TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2
+
+define Device/tl-wdr7500-v3
+    $(Device/tplink-8mlzma)
+    BOARDNAME := ARCHER-C7
+    DEVICE_PROFILE := ARCHERC7
+    TPLINK_HWID := 0x75000003
+endef
+TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2 tl-wdr7500-v3
 
 define Device/antminer-s1
     $(Device/tplink-8mlzma)
-- 
cgit v1.2.3