From c77c54e6845c201483a75dfc931f7065d3d35c84 Mon Sep 17 00:00:00 2001
From: John Crispin <blogic@openwrt.org>
Date: Sun, 15 Feb 2015 19:45:29 +0000
Subject: ar71xx: add v3.18 support

Signed-off-by: John Crispin <blogic@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@44456 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 .../patches-3.18/432-spi-rb4xx-spi-driver.patch    | 25 ++++++++++++++++++++++
 1 file changed, 25 insertions(+)
 create mode 100644 target/linux/ar71xx/patches-3.18/432-spi-rb4xx-spi-driver.patch

(limited to 'target/linux/ar71xx/patches-3.18/432-spi-rb4xx-spi-driver.patch')

diff --git a/target/linux/ar71xx/patches-3.18/432-spi-rb4xx-spi-driver.patch b/target/linux/ar71xx/patches-3.18/432-spi-rb4xx-spi-driver.patch
new file mode 100644
index 0000000000..27159b3bb2
--- /dev/null
+++ b/target/linux/ar71xx/patches-3.18/432-spi-rb4xx-spi-driver.patch
@@ -0,0 +1,25 @@
+--- a/drivers/spi/Kconfig
++++ b/drivers/spi/Kconfig
+@@ -433,6 +433,12 @@ config SPI_QUP
+ 	  This driver can also be built as a module.  If so, the module
+ 	  will be called spi_qup.
+ 
++config SPI_RB4XX
++	tristate "Mikrotik RB4XX SPI master"
++	depends on SPI_MASTER && ATH79_MACH_RB4XX
++	help
++	  SPI controller driver for the Mikrotik RB4xx series boards.
++
+ config SPI_S3C24XX
+ 	tristate "Samsung S3C24XX series SPI"
+ 	depends on ARCH_S3C24XX
+--- a/drivers/spi/Makefile
++++ b/drivers/spi/Makefile
+@@ -62,6 +62,7 @@ spi-pxa2xx-platform-$(CONFIG_SPI_PXA2XX_
+ spi-pxa2xx-platform-$(CONFIG_SPI_PXA2XX_DMA)	+= spi-pxa2xx-dma.o
+ obj-$(CONFIG_SPI_PXA2XX)		+= spi-pxa2xx-platform.o
+ obj-$(CONFIG_SPI_PXA2XX_PCI)		+= spi-pxa2xx-pci.o
++obj-$(CONFIG_SPI_RB4XX)			+= spi-rb4xx.o
+ obj-$(CONFIG_SPI_QUP)			+= spi-qup.o
+ obj-$(CONFIG_SPI_ROCKCHIP)		+= spi-rockchip.o
+ obj-$(CONFIG_SPI_RSPI)			+= spi-rspi.o
-- 
cgit v1.2.3