From 8cf67728d3b41c47ee5e322bb8c2908696380f24 Mon Sep 17 00:00:00 2001
From: Andreas Ziegler <dev@andreas-ziegler.de>
Date: Sun, 6 Oct 2019 19:48:34 +0200
Subject: ath79: add support for UniFi AC-LR

The Unifi AC-LR has identical hardware to the Unifi AC-Lite.
The antenna setup is different according to the vendor,
which explains the thicker enclosure.

Therefore, it is helpful to know the exact device variant,
instead of having "Ubiquiti UniFi-AC-LITE/LR".

Signed-off-by: Andreas Ziegler <dev@andreas-ziegler.de>
[fix legacy name in commit message; add old boardname to
SUPPORTED_DEVICES]
Signed-off-by: David Bauer <mail@david-bauer.net>
(cherry picked from commit 07c1ddf522dbe6085af664cf03a41f636a70b99c)
Signed-off-by: David Bauer <mail@david-bauer.net>
---
 target/linux/ath79/image/generic-ubnt.mk | 7 +++++++
 1 file changed, 7 insertions(+)

(limited to 'target/linux/ath79/image/generic-ubnt.mk')

diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index c51d743a35..fdc0d28033 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -177,6 +177,13 @@ define Device/ubnt_unifiac-lite
 endef
 TARGET_DEVICES += ubnt_unifiac-lite
 
+define Device/ubnt_unifiac-lr
+  $(Device/ubnt_unifiac)
+  DEVICE_TITLE := Ubiquiti UniFi AC-LR
+  SUPPORTED_DEVICES += unifiac-lite ubnt,unifiac-lite
+endef
+TARGET_DEVICES += ubnt_unifiac-lr
+
 define Device/ubnt_unifiac-mesh
   $(Device/ubnt_unifiac)
   DEVICE_TITLE := Ubiquiti UniFi AC-Mesh
-- 
cgit v1.2.3