From 56fddc2577baf194d1e9a7b37d454d12ff9fb469 Mon Sep 17 00:00:00 2001
From: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Date: Wed, 27 Jun 2018 12:10:33 +0200
Subject: ath79: sync naming of Ubiquiti devices

Use a Unifi AC Lite board-/image name consistent with other Ubiquiti
devices.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---
 .../linux/ath79/base-files/etc/board.d/02_network  |   2 +-
 .../etc/hotplug.d/firmware/11-ath10k-caldata       |   2 +-
 .../linux/ath79/dts/qca9563_ubnt-unifiac-lite.dts  | 143 ---------------------
 .../linux/ath79/dts/qca9563_ubnt_unifiac-lite.dts  | 143 +++++++++++++++++++++
 target/linux/ath79/image/generic-ubnt.mk           |   9 +-
 5 files changed, 150 insertions(+), 149 deletions(-)
 delete mode 100644 target/linux/ath79/dts/qca9563_ubnt-unifiac-lite.dts
 create mode 100644 target/linux/ath79/dts/qca9563_ubnt_unifiac-lite.dts

(limited to 'target/linux/ath79')

diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index e2a45b0526..e880abe5ac 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -15,7 +15,7 @@ ath79_setup_interfaces()
 	"avm,fritz300e"|\
 	"tplink,tl-mr10u"|\
 	"tplink,tl-wr703n"|\
-	"ubnt,ubnt-unifiac-lite"|\
+	"ubnt,unifiac-lite"|\
 	"ubnt,unifi")
 		ucidef_set_interface_lan "eth0"
 		;;
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index 20df5a220f..c3cc4d9986 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -95,7 +95,7 @@ case "$FIRMWARE" in
 		ath10kcal_extract "art" 20480 2116
 		ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth1/address) -2)
 		;;
-	"ubnt,ubnt-unifiac-lite")
+	"ubnt,unifiac-lite")
 		ath10kcal_extract "EEPROM" 20480 2116
 		;;
 	esac
diff --git a/target/linux/ath79/dts/qca9563_ubnt-unifiac-lite.dts b/target/linux/ath79/dts/qca9563_ubnt-unifiac-lite.dts
deleted file mode 100644
index 993f78bb19..0000000000
--- a/target/linux/ath79/dts/qca9563_ubnt-unifiac-lite.dts
+++ /dev/null
@@ -1,143 +0,0 @@
-// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-/dts-v1/;
-
-#include <dt-bindings/gpio/gpio.h>
-#include <dt-bindings/input/input.h>
-
-#include "qca956x.dtsi"
-
-/ {
-	compatible = "ubnt,ubnt-unifiac-lite", "qca,qca9563";
-	model = "Ubiquiti UniFi-AC-LITE/MESH/LR";
-
-	chosen {
-		bootargs = "console=ttyS0,115200n8";
-	};
-
-	leds {
-		compatible = "gpio-leds";
-
-		wifi_ac {
-			label = "ubnt:white:dome";
-			gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
-			default-state = "off";
-			linux,default-trigger = "phy0tpt";
-		};
-
-		wifi_n {
-			label = "ubnt:blue:dome";
-			gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
-			default-state = "off";
-			linux,default-trigger = "phy1tpt";
-		};
-
-	};
-
-	keys {
-		compatible = "gpio-keys";
-		#address-cells = <1>;
-		#size-cells = <0>;
-
-		reset {
-			label = "Reset button";
-			linux,code = <KEY_RESTART>;
-			gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
-			debounce-interval = <60>;
-		};
-	};
-};
-
-&uart {
-	status = "okay";
-};
-
-&gpio {
-	status = "okay";
-};
-
-&pcie {
-	status = "okay";
-};
-
-&spi {
-	status = "okay";
-	num-cs = <1>;
-
-	flash@0 {
-		#address-cells = <1>;
-		#size-cells = <1>;
-		compatible = "jedec,spi-nor";
-		reg = <0>;
-		spi-max-frequency = <25000000>;
-
-		partitions {
-			compatible = "fixed-partitions";
-			#address-cells = <1>;
-			#size-cells = <1>;
-
-			partition@0 {
-				label = "u-boot";
-				reg = <0x000000 0x060000>;
-				read-only;
-			};
-
-			partition@60000 {
-				label = "u-boot-env";
-				reg = <0x060000 0x010000>;
-				read-only;
-			};
-
-			partition@70000 {
-				label = "firmware";
-				reg = <0x070000 0x790000>;
-			};
-
-			partition@800000 {
-				label = "ubnt-airos";
-				reg = <0x800000 0x790000>;
-				read-only;
-			};
-
-			partition@f90000 {
-				label = "bs";
-				reg = <0xf90000 0x020000>;
-				read-only;
-			};
-
-			partition@fb0000 {
-				label = "cfg";
-				reg = <0xfb0000 0x040000>;
-				read-only;
-			};
-
-			eeprom: partition@ff0000 {
-				label = "EEPROM";
-				reg = <0xff0000 0x010000>;
-				read-only;
-			};
-		};
-	};
-};
-
-&mdio0 {
-	status = "okay";
-
-	phy-mask = <4>;
-	phy4: ethernet-phy@4 {
-		phy-mode = "sgmii";
-		reg = <4>;
-	};
-};
-
-&eth0 {
-	status = "okay";
-
-	mtd-mac-address = <&eeprom 0x0>;
-	phy-handle = <&phy4>;
-};
-
-&wmac {
-	status = "okay";
-	mtd-cal-data = <&eeprom 0x1000>;
-	mtd-mac-address = <&eeprom 0x0>;
-};
diff --git a/target/linux/ath79/dts/qca9563_ubnt_unifiac-lite.dts b/target/linux/ath79/dts/qca9563_ubnt_unifiac-lite.dts
new file mode 100644
index 0000000000..ff24338ca0
--- /dev/null
+++ b/target/linux/ath79/dts/qca9563_ubnt_unifiac-lite.dts
@@ -0,0 +1,143 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca956x.dtsi"
+
+/ {
+	compatible = "ubnt,unifiac-lite", "qca,qca9563";
+	model = "Ubiquiti UniFi-AC-LITE/MESH/LR";
+
+	chosen {
+		bootargs = "console=ttyS0,115200n8";
+	};
+
+	leds {
+		compatible = "gpio-leds";
+
+		wifi_ac {
+			label = "ubnt:white:dome";
+			gpios = <&gpio 7 GPIO_ACTIVE_LOW>;
+			default-state = "off";
+			linux,default-trigger = "phy0tpt";
+		};
+
+		wifi_n {
+			label = "ubnt:blue:dome";
+			gpios = <&gpio 8 GPIO_ACTIVE_LOW>;
+			default-state = "off";
+			linux,default-trigger = "phy1tpt";
+		};
+
+	};
+
+	keys {
+		compatible = "gpio-keys";
+		#address-cells = <1>;
+		#size-cells = <0>;
+
+		reset {
+			label = "Reset button";
+			linux,code = <KEY_RESTART>;
+			gpios = <&gpio 2 GPIO_ACTIVE_LOW>;
+			debounce-interval = <60>;
+		};
+	};
+};
+
+&uart {
+	status = "okay";
+};
+
+&gpio {
+	status = "okay";
+};
+
+&pcie {
+	status = "okay";
+};
+
+&spi {
+	status = "okay";
+	num-cs = <1>;
+
+	flash@0 {
+		#address-cells = <1>;
+		#size-cells = <1>;
+		compatible = "jedec,spi-nor";
+		reg = <0>;
+		spi-max-frequency = <25000000>;
+
+		partitions {
+			compatible = "fixed-partitions";
+			#address-cells = <1>;
+			#size-cells = <1>;
+
+			partition@0 {
+				label = "u-boot";
+				reg = <0x000000 0x060000>;
+				read-only;
+			};
+
+			partition@60000 {
+				label = "u-boot-env";
+				reg = <0x060000 0x010000>;
+				read-only;
+			};
+
+			partition@70000 {
+				label = "firmware";
+				reg = <0x070000 0x790000>;
+			};
+
+			partition@800000 {
+				label = "ubnt-airos";
+				reg = <0x800000 0x790000>;
+				read-only;
+			};
+
+			partition@f90000 {
+				label = "bs";
+				reg = <0xf90000 0x020000>;
+				read-only;
+			};
+
+			partition@fb0000 {
+				label = "cfg";
+				reg = <0xfb0000 0x040000>;
+				read-only;
+			};
+
+			eeprom: partition@ff0000 {
+				label = "EEPROM";
+				reg = <0xff0000 0x010000>;
+				read-only;
+			};
+		};
+	};
+};
+
+&mdio0 {
+	status = "okay";
+
+	phy-mask = <4>;
+	phy4: ethernet-phy@4 {
+		phy-mode = "sgmii";
+		reg = <4>;
+	};
+};
+
+&eth0 {
+	status = "okay";
+
+	mtd-mac-address = <&eeprom 0x0>;
+	phy-handle = <&phy4>;
+};
+
+&wmac {
+	status = "okay";
+	mtd-cal-data = <&eeprom 0x1000>;
+	mtd-mac-address = <&eeprom 0x0>;
+};
diff --git a/target/linux/ath79/image/generic-ubnt.mk b/target/linux/ath79/image/generic-ubnt.mk
index 900167f626..aa898be2ee 100644
--- a/target/linux/ath79/image/generic-ubnt.mk
+++ b/target/linux/ath79/image/generic-ubnt.mk
@@ -80,7 +80,7 @@ define Device/ubnt_unifi
 endef
 TARGET_DEVICES += ubnt_unifi
 
-define Device/ubnt-unifiac
+define Device/ubnt_unifiac
   DEVICE_PACKAGES := kmod-usb-core kmod-usb2
   DEVICE_PROFILE := UBNT
   IMAGE_SIZE := 7744k
@@ -89,12 +89,13 @@ define Device/ubnt-unifiac
 endef
 
 
-define Device/ubnt-unifiac-lite
-  $(Device/ubnt-unifiac)
+define Device/ubnt_unifiac-lite
+  $(Device/ubnt_unifiac)
   DEVICE_TITLE := Ubiquiti UniFi AC-Lite
+  SUPPORTED_DEVICES += ubnt-unifiac-lite
   DEVICE_PACKAGES := kmod-ath10k ath10k-firmware-qca988x
   DEVICE_PROFILE += UBNTUNIFIACLITE
   BOARDNAME := UBNT-UF-AC-LITE
   ATH_SOC := qca9563
 endef
-TARGET_DEVICES += ubnt-unifiac-lite
+TARGET_DEVICES += ubnt_unifiac-lite
-- 
cgit v1.2.3