From ae7680dc4bf914d640dba32c8f1c36631768a56a Mon Sep 17 00:00:00 2001
From: Sven Eckelmann <sven@narfation.org>
Date: Mon, 23 Nov 2020 13:41:34 +0100
Subject: ath79: Add support for OpenMesh MR1750 v1

Device specifications:
======================

* Qualcomm/Atheros QCA9558 ver 1 rev 0
* 720/600/240 MHz (CPU/DDR/AHB)
* 128 MB of RAM
* 16 MB of SPI NOR flash
  - 2x 7 MB available; but one of the 7 MB regions is the recovery image
* 3T3R 2.4 GHz Wi-Fi (11n)
* 3T3R 5 GHz Wi-Fi (11ac)
* 6x GPIO-LEDs (2x wifi, 2x status, 1x lan, 1x power)
* 1x GPIO-button (reset)
* external h/w watchdog (enabled by default))
* TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX)
* 1x ethernet
  - AR8035 ethernet PHY (RGMII)
  - 10/100/1000 Mbps Ethernet
  - 802.3af POE
  - used as LAN interface
* 12-24V 1A DC
* internal antennas

Flashing instructions:
======================

Various methods can be used to install the actual image on the flash.
Two easy ones are:

ap51-flash
----------

The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be
used to transfer the image to the u-boot when the device boots up.

initramfs from TFTP
-------------------

The serial console must be used to access the u-boot shell during bootup.
It can then be used to first boot up the initramfs image from a TFTP server
(here with the IP 192.168.1.21):

   setenv serverip 192.168.1.21
   setenv ipaddr 192.168.1.1
   tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr

The actual sysupgrade image can then be transferred (on the LAN port) to the
device via

  scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/

On the device, the sysupgrade must then be started using

  sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin

Signed-off-by: Sven Eckelmann <sven@narfation.org>
[rebase, apply shared DTSI/device node, add LED migration]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
---
 target/linux/ath79/dts/qca9558_openmesh_mr1750-v1.dts    | 16 ++++++++++++++++
 .../linux/ath79/generic/base-files/etc/board.d/01_leds   |  3 ++-
 .../ath79/generic/base-files/etc/board.d/02_network      |  1 +
 .../base-files/etc/hotplug.d/firmware/11-ath10k-caldata  |  4 ++++
 .../generic/base-files/etc/uci-defaults/04_led_migration |  3 ++-
 .../ath79/generic/base-files/lib/upgrade/platform.sh     |  1 +
 target/linux/ath79/image/generic.mk                      | 11 +++++++++++
 7 files changed, 37 insertions(+), 2 deletions(-)
 create mode 100644 target/linux/ath79/dts/qca9558_openmesh_mr1750-v1.dts

(limited to 'target/linux/ath79')

diff --git a/target/linux/ath79/dts/qca9558_openmesh_mr1750-v1.dts b/target/linux/ath79/dts/qca9558_openmesh_mr1750-v1.dts
new file mode 100644
index 0000000000..11eb6dfb55
--- /dev/null
+++ b/target/linux/ath79/dts/qca9558_openmesh_mr1750-v1.dts
@@ -0,0 +1,16 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "qca9558_openmesh_mr.dtsi"
+
+/ {
+	compatible = "openmesh,mr1750-v1", "qca,qca9558";
+	model = "OpenMesh MR1750 v1";
+};
+
+&led_wifi2g {
+	linux,default-trigger = "phy1tpt";
+};
+
+&led_wifi5g {
+	linux,default-trigger = "phy0tpt";
+};
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/01_leds b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
index 8fba9bc0e7..2cdad7dd77 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/generic/base-files/etc/board.d/01_leds
@@ -159,7 +159,8 @@ comfast,cf-wr752ac-v1|\
 engenius,eap300-v2|\
 enterasys,ws-ap3705i|\
 openmesh,mr900-v1|\
-openmesh,mr900-v2)
+openmesh,mr900-v2|\
+openmesh,mr1750-v1)
 	ucidef_set_led_netdev "lan" "LAN" "blue:lan" "eth0"
 	;;
 compex,wpj344-16m|\
diff --git a/target/linux/ath79/generic/base-files/etc/board.d/02_network b/target/linux/ath79/generic/base-files/etc/board.d/02_network
index 76bbd92c21..ef6b70c902 100755
--- a/target/linux/ath79/generic/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/generic/base-files/etc/board.d/02_network
@@ -50,6 +50,7 @@ ath79_setup_interfaces()
 	openmesh,mr600-v2|\
 	openmesh,mr900-v1|\
 	openmesh,mr900-v2|\
+	openmesh,mr1750-v1|\
 	pcs,cap324|\
 	pisen,ts-d084|\
 	pisen,wmb001n|\
diff --git a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index 99d2353ac1..d1a4767648 100644
--- a/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -96,6 +96,10 @@ case "$FIRMWARE" in
 		caldata_extract "art" 0x5000 0x844
 		ath10k_patch_mac $(mtd_get_mac_binary art 0xc)
 		;;
+	openmesh,mr1750-v1)
+		caldata_extract "ART" 0x5000 0x844
+		ath10k_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +16)
+		;;
 	openmesh,om5p-ac-v2)
 		caldata_extract "art" 0x5000 0x844
 		ath10k_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +16)
diff --git a/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration b/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
index 453bf3b911..1d8909f688 100644
--- a/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
+++ b/target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
@@ -24,7 +24,8 @@ openmesh,mr600-v2)
 	migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g"
 	;;
 openmesh,mr900-v1|\
-openmesh,mr900-v2)
+openmesh,mr900-v2|\
+openmesh,mr1750-v1)
 	migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g" ":wan=:lan"
 	;;
 pcs,cap324)
diff --git a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
index 76512758b6..01a9f61943 100644
--- a/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
@@ -54,6 +54,7 @@ platform_do_upgrade() {
 	openmesh,mr600-v2|\
 	openmesh,mr900-v1|\
 	openmesh,mr900-v2|\
+	openmesh,mr1750-v1|\
 	openmesh,om2p-v2|\
 	openmesh,om2p-v4|\
 	openmesh,om2p-hs-v1|\
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 3d569c9532..92e9458b37 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -1590,6 +1590,17 @@ define Device/openmesh_mr900-v2
 endef
 TARGET_DEVICES += openmesh_mr900-v2
 
+define Device/openmesh_mr1750-v1
+  $(Device/openmesh_common_64k)
+  SOC := qca9558
+  DEVICE_MODEL := MR1750
+  DEVICE_VARIANT := v1
+  DEVICE_PACKAGES += kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  OPENMESH_CE_TYPE := MR1750
+  SUPPORTED_DEVICES += mr1750
+endef
+TARGET_DEVICES += openmesh_mr1750-v1
+
 define Device/openmesh_om2p-v2
   $(Device/openmesh_common_256k)
   SOC := ar9330
-- 
cgit v1.2.3