From ace5c1dac5a45de03650acfbaa65a4b79554151e Mon Sep 17 00:00:00 2001
From: Travis Kemen <thepeople@openwrt.org>
Date: Fri, 9 May 2008 19:07:16 +0000
Subject: fix uboot not building

SVN-Revision: 11100
---
 target/linux/avr32/image/u-boot/Makefile | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

(limited to 'target/linux/avr32/image')

diff --git a/target/linux/avr32/image/u-boot/Makefile b/target/linux/avr32/image/u-boot/Makefile
index ec4f7fbbbb..a24efc4c47 100644
--- a/target/linux/avr32/image/u-boot/Makefile
+++ b/target/linux/avr32/image/u-boot/Makefile
@@ -29,7 +29,8 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-	dd if=$(PKG_BUILD_DIR)/u-boot.bin of=$(BIN_DIR)/u-boot-$(CONFIG_AVR32_UBOOT_TARGET).bin bs=64k conv=sync
+	mkdir -p $(BIN_DIR)
+	dd if=$(PKG_BUILD_DIR)/u-boot.bin of=$(BIN_DIR)/u-boot-$(UBOOT_CONFIG).bin bs=64k conv=sync
 endef
 
 $(eval $(call Build/DefaultTargets))
-- 
cgit v1.2.3