From 56231056ea784f1cec6450f649b1adaed1f56366 Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Thu, 6 Sep 2007 16:27:37 +0000
Subject: strip the kernel version suffix from target directories, except for
 brcm-2.4 (the -2.4 will be included in the board name here).
 CONFIG_LINUX_<ver>_<board> becomes CONFIG_TARGET_<board>, same for profiles.

SVN-Revision: 8653
---
 target/linux/magicbox/image/Makefile | 37 ++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)
 create mode 100644 target/linux/magicbox/image/Makefile

(limited to 'target/linux/magicbox/image/Makefile')

diff --git a/target/linux/magicbox/image/Makefile b/target/linux/magicbox/image/Makefile
new file mode 100644
index 0000000000..f99590f1ea
--- /dev/null
+++ b/target/linux/magicbox/image/Makefile
@@ -0,0 +1,37 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+	cp $(LINUX_DIR)/arch/ppc/boot/images/uImage $(KDIR)/uImage
+endef
+
+define Image/BuildKernel
+	cp $(KDIR)/uImage $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-uImage
+endef
+
+define Image/Build
+	$(call Image/Build/$(1),$(1))
+endef
+
+define Image/Build/jffs2-64k
+	( \
+		dd if=$(KDIR)/uImage bs=1024k conv=sync; \
+		dd if=$(KDIR)/root.$(1) bs=65536 conv=sync; \
+	) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+endef
+
+define Image/Build/squashfs
+	$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+	( \
+		dd if=$(LINUX_DIR)/arch/ppc/boot/images/uImage bs=1024k conv=sync; \
+		dd if=$(KDIR)/root.$(1) bs=65536 conv=sync; \
+	) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).img
+endef
+
+$(eval $(call BuildImage))
-- 
cgit v1.2.3