From 66458c49aa14ebc9ba2e4f9b6a323b8ff122807b Mon Sep 17 00:00:00 2001
From: John Crispin <john@phrozen.org>
Date: Fri, 2 Aug 2019 10:33:28 +0200
Subject: mediatek: add v4.19 support

Bump the target to v4.19. Add a patch with additional eth driver
fixes/features that MTK provided aswell as the driver for the new mt7530
switch.

Signed-off-by: John Crispin <john@phrozen.org>
---
 target/linux/mediatek/image/mt7622.mk | 23 ++++++++++++++++++++---
 1 file changed, 20 insertions(+), 3 deletions(-)

(limited to 'target/linux/mediatek/image')

diff --git a/target/linux/mediatek/image/mt7622.mk b/target/linux/mediatek/image/mt7622.mk
index 86b25ce33c..1644a3ea68 100644
--- a/target/linux/mediatek/image/mt7622.mk
+++ b/target/linux/mediatek/image/mt7622.mk
@@ -1,9 +1,26 @@
 define Device/MTK-RFB1
-  DEVICE_TITLE := MTK7622 rfb1 AP 
+  DEVICE_TITLE := MTK7622 rfb1 AP
   DEVICE_DTS := mt7622-rfb1
   DEVICE_DTS_DIR := $(DTS_DIR)/mediatek
-  SUPPORTED_DEVICES := mt7622
   DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb3 \
-			kmod-ata-core kmod-ata-ahci-mtk 
+			kmod-ata-core kmod-ata-ahci-mtk
 endef
 TARGET_DEVICES += MTK-RFB1
+
+define Device/MTK-LYNX-RFB1
+  DEVICE_TITLE := MTK7622 Lynx rfb1 AP
+  DEVICE_DTS := mt7622-lynx-rfb1
+  DEVICE_DTS_DIR := $(DTS_DIR)/mediatek
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb3 \
+			kmod-ata-core kmod-ata-ahci-mtk
+endef
+TARGET_DEVICES += MTK-LYNX-RFB1
+
+define Device/BPI-R64
+  DEVICE_TITLE := Bannan Pi R64
+  DEVICE_DTS := mt7622-bananapi-bpi-r64
+  DEVICE_DTS_DIR := $(DTS_DIR)/mediatek
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb3 \
+			kmod-ata-core kmod-ata-ahci-mtk
+endef
+TARGET_DEVICES += BPI-R64
-- 
cgit v1.2.3