From e2b57ecf5f1f50f7b5f5644e483e06dd67a3cb5f Mon Sep 17 00:00:00 2001
From: Nicolas Thill <nico@openwrt.org>
Date: Mon, 12 Apr 2010 23:15:56 +0000
Subject: define a shared IMG_PREFIX variable used as a basename for image
 files, it contains board & subtarget infos (if appropriate) allowing
 subtargets to share the same bin directory without overwriting each other's
 files

SVN-Revision: 20834
---
 target/linux/pxcab/image/Makefile | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

(limited to 'target/linux/pxcab/image/Makefile')

diff --git a/target/linux/pxcab/image/Makefile b/target/linux/pxcab/image/Makefile
index ae551fa961..b2e08f0734 100644
--- a/target/linux/pxcab/image/Makefile
+++ b/target/linux/pxcab/image/Makefile
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -13,8 +13,8 @@ endef
 
 define Image/BuildKernel
 	mkdir -p $(BIN_DIR)
-	cp $(KDIR)/zImage $(BIN_DIR)/openwrt-$(BOARD)-zImage
-	cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+	cp $(KDIR)/zImage $(BIN_DIR)/$(IMG_PREFIX)-zImage
+	cp $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux.elf
 endef
 
 $(eval $(call BuildImage))
-- 
cgit v1.2.3