From 968894ad08485a41c324de96e5c0c2420bb3a1f8 Mon Sep 17 00:00:00 2001
From: Gabor Juhos <juhosg@openwrt.org>
Date: Tue, 10 Jul 2007 11:02:07 +0000
Subject: fix errors in image generation Makefiles, thanks to Thomas Langer
 (fixes #2060)

SVN-Revision: 7904
---
 target/linux/adm5120-2.6/image/Makefile   | 4 ++--
 target/linux/adm5120eb-2.6/image/Makefile | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

(limited to 'target/linux')

diff --git a/target/linux/adm5120-2.6/image/Makefile b/target/linux/adm5120-2.6/image/Makefile
index 352ebf480f..bf4ca5711b 100644
--- a/target/linux/adm5120-2.6/image/Makefile
+++ b/target/linux/adm5120-2.6/image/Makefile
@@ -91,7 +91,7 @@ define Image/Build
 ifneq ($(1),jffs2-256k)
 ifneq ($(1),jffs2-128k)
 	$(call Image/Build/Compex,$(1),wp54g-wrt,$(patsubst jffs2-%,jffs2,$(1)),WP54G-WRT)
-ifeq (CONFIG_DEVEL,y)
+ifeq ($(CONFIG_DEVEL),y)
 	$(call Image/Build/Edimax,$(1),br-6104k,$(patsubst jffs2-%,jffs2,$(1)),BR-6104K)
 	$(call Image/Build/Edimax,$(1),br-6104kp,$(patsubst jffs2-%,jffs2,$(1)),BR-6104KP)
 	$(call Image/Build/Edimax,$(1),br-6114wg,$(patsubst jffs2-%,jffs2,$(1)),BR-6114WG)
@@ -152,7 +152,7 @@ endef
 define Image/Build/Initramfs
 	$(call Image/Build/Initramfs/RouterBoard)
 	$(call Image/Build/LZMAKernel/Compex,wp54g-wrt,bin)
-ifeq (CONFIG_DEVEL,y)
+ifeq ($(CONFIG_DEVEL),y)
 	$(call Image/Build/LZMAKernel/Generic,generic,bin)
 	$(call Image/Build/LZMAKernel/Generic,np27g,bin)
 	$(call Image/Build/LZMAKernel/Generic,wp54g,bin)
diff --git a/target/linux/adm5120eb-2.6/image/Makefile b/target/linux/adm5120eb-2.6/image/Makefile
index 5772272090..7644a07ada 100644
--- a/target/linux/adm5120eb-2.6/image/Makefile
+++ b/target/linux/adm5120eb-2.6/image/Makefile
@@ -70,7 +70,7 @@ endef
 
 define Image/Build/Initramfs
 # this line is here intentionally
-ifeq (CONFIG_DEVEL,y)
+ifeq ($(CONFIG_DEVEL),y)
 	$(call Image/Build/LZMAKernel/ZyXEL,p-334wt,bin)
 	$(call Image/Build/LZMAKernel/ZyXEL,p-335,bin)
 endif
-- 
cgit v1.2.3