From aadca035bc77e6d1201c38601091b8daf6385300 Mon Sep 17 00:00:00 2001
From: Jo-Philipp Wich <jo@mein.io>
Date: Sun, 13 May 2018 18:33:47 +0200
Subject: at91: sama5d4: fix bad mkubifs options

Drop the "-x lzo" compression type override from MKUBIFS_OPTS since we
do not support it in mkfs.ubifs. Attempting to use LZO compression results
in "Error: bad compressor name".

The build system also appends an explicit "--compr=zlib" to the mkfs command
line, turning the "-x" flag into a no-op anyway.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
---
 target/linux/at91/image/sama5d4.mk | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

(limited to 'target/linux')

diff --git a/target/linux/at91/image/sama5d4.mk b/target/linux/at91/image/sama5d4.mk
index 554b9890df..1140c3c4b2 100644
--- a/target/linux/at91/image/sama5d4.mk
+++ b/target/linux/at91/image/sama5d4.mk
@@ -13,7 +13,7 @@ define Device/at91-sama5d4_xplained
   BLOCKSIZE := 256k
   PAGESIZE := 4096
   SUBPAGESIZE := 2048
-  MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082 -x lzo
+  MKUBIFS_OPTS := -m $$(PAGESIZE) -e 248KiB -c 2082
   $(Device/evaluation-sdimage)
 endef
 TARGET_DEVICES += at91-sama5d4_xplained
-- 
cgit v1.2.3