From e2ec3f7550ccf66a000262b7c33a2a87524c5257 Mon Sep 17 00:00:00 2001
From: Jonas Gorski <jonas.gorski@gmail.com>
Date: Sun, 11 Feb 2018 22:31:36 +0100
Subject: mvebu: fix sysupgrade from 17.04 for clearfog pro

When clearfog was renamed to clearfog pro, it broke sysupgrade from
17.04 as the new images now get rejected as incompatible. Fix this by
adding the legacy boardname to the compatible devices.

Fixes: ec4a8c6dee81 ("mvebu: ClearFog renamed upstream to ClearFog Pro")
Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
---
 target/linux/mvebu/image/Makefile | 1 +
 1 file changed, 1 insertion(+)

(limited to 'target/linux')

diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 989ba5084b..812d946f66 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -199,6 +199,7 @@ define Device/armada-388-clearfog-pro
   IMAGE/sdcard.img.gz := boot-scr-cfpro | boot-img | sdcard-img | gzip | append-metadata
   IMAGE_NAME = $$(IMAGE_PREFIX)-$$(2)
   DEVICE_DTS := armada-388-clearfog-pro armada-388-clearfog-base
+  SUPPORTED_DEVICES := armada-388-clearfog-pro armada-388-clearfog
 endef
 TARGET_DEVICES += armada-388-clearfog-pro
 
-- 
cgit v1.2.3