From 31639e70b8bbfdf39c9e6caf4f43b0a8d5b30539 Mon Sep 17 00:00:00 2001
From: Gabor Juhos <juhosg@openwrt.org>
Date: Wed, 23 Oct 2013 15:43:26 +0000
Subject: ar71xx: rename 'nand' subtarget to 'mikrotik'

It is for Mikrotik devices only, rename the subtarget
to reflect that. Also fix the wget2nand script to use
the new image names.

Based on the patch by Stefan Agner:
http://patchwork.openwrt.org/patch/4123/

Signed-off-by: Gabor Juhos <juhosg@openwrt.org>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38509 3c298f89-4303-0410-b956-a3cf2f4a3e73
---
 target/linux/ar71xx/Makefile                       |  2 +-
 target/linux/ar71xx/base-files/sbin/wget2nand      |  4 +--
 target/linux/ar71xx/mikrotik/config-default        | 34 ++++++++++++++++++++++
 .../linux/ar71xx/mikrotik/profiles/01-minimal.mk   | 16 ++++++++++
 target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk  | 16 ++++++++++
 target/linux/ar71xx/mikrotik/target.mk             |  8 +++++
 target/linux/ar71xx/nand/config-default            | 34 ----------------------
 target/linux/ar71xx/nand/profiles/01-minimal.mk    | 16 ----------
 target/linux/ar71xx/nand/profiles/02-ath5k.mk      | 16 ----------
 target/linux/ar71xx/nand/target.mk                 |  8 -----
 10 files changed, 77 insertions(+), 77 deletions(-)
 create mode 100644 target/linux/ar71xx/mikrotik/config-default
 create mode 100644 target/linux/ar71xx/mikrotik/profiles/01-minimal.mk
 create mode 100644 target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk
 create mode 100644 target/linux/ar71xx/mikrotik/target.mk
 delete mode 100644 target/linux/ar71xx/nand/config-default
 delete mode 100644 target/linux/ar71xx/nand/profiles/01-minimal.mk
 delete mode 100644 target/linux/ar71xx/nand/profiles/02-ath5k.mk
 delete mode 100644 target/linux/ar71xx/nand/target.mk

(limited to 'target')

diff --git a/target/linux/ar71xx/Makefile b/target/linux/ar71xx/Makefile
index 019e3cb13d..a59a124d1d 100644
--- a/target/linux/ar71xx/Makefile
+++ b/target/linux/ar71xx/Makefile
@@ -11,7 +11,7 @@ BOARD:=ar71xx
 BOARDNAME:=Atheros AR7xxx/AR9xxx
 FEATURES:=squashfs targz mips16
 CPU_TYPE=34kc
-SUBTARGETS:=generic nand
+SUBTARGETS:=generic mikrotik
 
 LINUX_VERSION:=3.10.17
 
diff --git a/target/linux/ar71xx/base-files/sbin/wget2nand b/target/linux/ar71xx/base-files/sbin/wget2nand
index f80eecd219..8175a9e2a1 100755
--- a/target/linux/ar71xx/base-files/sbin/wget2nand
+++ b/target/linux/ar71xx/base-files/sbin/wget2nand
@@ -27,8 +27,8 @@ url=$1
         exit 1
 }
 
-url_kernel=$url/openwrt-ar71xx-nand-vmlinux-lzma.elf
-url_rootfs=$url/openwrt-ar71xx-nand-rootfs.tar.gz
+url_kernel=$url/openwrt-ar71xx-mikrotik-vmlinux-lzma.elf
+url_rootfs=$url/openwrt-ar71xx-mikrotik-rootfs.tar.gz
 
 mtd_kernel="$(find_mtd_part 'kernel')"
 mtd_rootfs="$(find_mtd_part 'rootfs')"
diff --git a/target/linux/ar71xx/mikrotik/config-default b/target/linux/ar71xx/mikrotik/config-default
new file mode 100644
index 0000000000..efa562c66e
--- /dev/null
+++ b/target/linux/ar71xx/mikrotik/config-default
@@ -0,0 +1,34 @@
+CONFIG_ATH79_MACH_RB2011=y
+CONFIG_ATH79_MACH_RB4XX=y
+CONFIG_ATH79_MACH_RB750=y
+CONFIG_ATH79_MACH_RB95X=y
+CONFIG_ATH79_ROUTERBOOT=y
+CONFIG_CMDLINE="rootfstype=yaffs noinitrd"
+# CONFIG_JFFS2_FS is not set
+CONFIG_LEDS_RB750=y
+CONFIG_MDIO_BITBANG=y
+CONFIG_MDIO_GPIO=y
+CONFIG_MTD_NAND=y
+CONFIG_MTD_NAND_AR934X=y
+CONFIG_MTD_NAND_ECC=y
+CONFIG_MTD_NAND_RB4XX=y
+CONFIG_MTD_NAND_RB750=y
+# CONFIG_MTD_SM_COMMON is not set
+# CONFIG_OVERLAYFS_FS is not set
+CONFIG_RLE_DECOMPRESS=y
+CONFIG_SPI_RB4XX=y
+CONFIG_SPI_RB4XX_CPLD=y
+# CONFIG_SQUASHFS is not set
+CONFIG_YAFFS_9BYTE_TAGS=y
+CONFIG_YAFFS_ALWAYS_CHECK_CHUNK_ERASED=y
+CONFIG_YAFFS_AUTO_YAFFS2=y
+# CONFIG_YAFFS_DISABLE_BACKGROUND is not set
+# CONFIG_YAFFS_DISABLE_BLOCK_REFRESHING is not set
+# CONFIG_YAFFS_DISABLE_TAGS_ECC is not set
+# CONFIG_YAFFS_DISABLE_WIDE_TNODES is not set
+# CONFIG_YAFFS_EMPTY_LOST_AND_FOUND is not set
+CONFIG_YAFFS_FS=y
+CONFIG_YAFFS_SHORT_NAMES_IN_RAM=y
+CONFIG_YAFFS_XATTR=y
+CONFIG_YAFFS_YAFFS1=y
+CONFIG_YAFFS_YAFFS2=y
diff --git a/target/linux/ar71xx/mikrotik/profiles/01-minimal.mk b/target/linux/ar71xx/mikrotik/profiles/01-minimal.mk
new file mode 100644
index 0000000000..3651c88ab2
--- /dev/null
+++ b/target/linux/ar71xx/mikrotik/profiles/01-minimal.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/DefaultNoWifi
+	NAME:=Default Profile (no WiFi)
+	PACKAGES:=
+endef
+
+define Profile/DefaultNoWifi/Description
+	Default package set compatible with most boards.
+endef
+$(eval $(call Profile,DefaultNoWifi))
diff --git a/target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk b/target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk
new file mode 100644
index 0000000000..a291ff68ae
--- /dev/null
+++ b/target/linux/ar71xx/mikrotik/profiles/02-ath5k.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2009-2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Ath5k
+	NAME:=Atheros WiFi (ath5k)
+	PACKAGES:=kmod-ath5k -kmod-ath9k
+endef
+
+define Profile/Ath5k/Description
+	Package set compatible with hardware using Atheros WiFi cards.
+endef
+$(eval $(call Profile,Ath5k))
diff --git a/target/linux/ar71xx/mikrotik/target.mk b/target/linux/ar71xx/mikrotik/target.mk
new file mode 100644
index 0000000000..45d2624cd4
--- /dev/null
+++ b/target/linux/ar71xx/mikrotik/target.mk
@@ -0,0 +1,8 @@
+BOARDNAME:=Mikrotik devices with NAND flash
+
+define Target/Description
+	Build firmware images for Atheros AR71xx/AR913x based Mikrotik boards.
+	e.g. MikroTik RB-4xx or RB-750
+endef
+
+
diff --git a/target/linux/ar71xx/nand/config-default b/target/linux/ar71xx/nand/config-default
deleted file mode 100644
index efa562c66e..0000000000
--- a/target/linux/ar71xx/nand/config-default
+++ /dev/null
@@ -1,34 +0,0 @@
-CONFIG_ATH79_MACH_RB2011=y
-CONFIG_ATH79_MACH_RB4XX=y
-CONFIG_ATH79_MACH_RB750=y
-CONFIG_ATH79_MACH_RB95X=y
-CONFIG_ATH79_ROUTERBOOT=y
-CONFIG_CMDLINE="rootfstype=yaffs noinitrd"
-# CONFIG_JFFS2_FS is not set
-CONFIG_LEDS_RB750=y
-CONFIG_MDIO_BITBANG=y
-CONFIG_MDIO_GPIO=y
-CONFIG_MTD_NAND=y
-CONFIG_MTD_NAND_AR934X=y
-CONFIG_MTD_NAND_ECC=y
-CONFIG_MTD_NAND_RB4XX=y
-CONFIG_MTD_NAND_RB750=y
-# CONFIG_MTD_SM_COMMON is not set
-# CONFIG_OVERLAYFS_FS is not set
-CONFIG_RLE_DECOMPRESS=y
-CONFIG_SPI_RB4XX=y
-CONFIG_SPI_RB4XX_CPLD=y
-# CONFIG_SQUASHFS is not set
-CONFIG_YAFFS_9BYTE_TAGS=y
-CONFIG_YAFFS_ALWAYS_CHECK_CHUNK_ERASED=y
-CONFIG_YAFFS_AUTO_YAFFS2=y
-# CONFIG_YAFFS_DISABLE_BACKGROUND is not set
-# CONFIG_YAFFS_DISABLE_BLOCK_REFRESHING is not set
-# CONFIG_YAFFS_DISABLE_TAGS_ECC is not set
-# CONFIG_YAFFS_DISABLE_WIDE_TNODES is not set
-# CONFIG_YAFFS_EMPTY_LOST_AND_FOUND is not set
-CONFIG_YAFFS_FS=y
-CONFIG_YAFFS_SHORT_NAMES_IN_RAM=y
-CONFIG_YAFFS_XATTR=y
-CONFIG_YAFFS_YAFFS1=y
-CONFIG_YAFFS_YAFFS2=y
diff --git a/target/linux/ar71xx/nand/profiles/01-minimal.mk b/target/linux/ar71xx/nand/profiles/01-minimal.mk
deleted file mode 100644
index 3651c88ab2..0000000000
--- a/target/linux/ar71xx/nand/profiles/01-minimal.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/DefaultNoWifi
-	NAME:=Default Profile (no WiFi)
-	PACKAGES:=
-endef
-
-define Profile/DefaultNoWifi/Description
-	Default package set compatible with most boards.
-endef
-$(eval $(call Profile,DefaultNoWifi))
diff --git a/target/linux/ar71xx/nand/profiles/02-ath5k.mk b/target/linux/ar71xx/nand/profiles/02-ath5k.mk
deleted file mode 100644
index a291ff68ae..0000000000
--- a/target/linux/ar71xx/nand/profiles/02-ath5k.mk
+++ /dev/null
@@ -1,16 +0,0 @@
-#
-# Copyright (C) 2009-2012 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Ath5k
-	NAME:=Atheros WiFi (ath5k)
-	PACKAGES:=kmod-ath5k -kmod-ath9k
-endef
-
-define Profile/Ath5k/Description
-	Package set compatible with hardware using Atheros WiFi cards.
-endef
-$(eval $(call Profile,Ath5k))
diff --git a/target/linux/ar71xx/nand/target.mk b/target/linux/ar71xx/nand/target.mk
deleted file mode 100644
index 45d2624cd4..0000000000
--- a/target/linux/ar71xx/nand/target.mk
+++ /dev/null
@@ -1,8 +0,0 @@
-BOARDNAME:=Mikrotik devices with NAND flash
-
-define Target/Description
-	Build firmware images for Atheros AR71xx/AR913x based Mikrotik boards.
-	e.g. MikroTik RB-4xx or RB-750
-endef
-
-
-- 
cgit v1.2.3