From 215ccb66e6abdaed0a41582d6b8c40ffa340eea7 Mon Sep 17 00:00:00 2001
From: Felix Fietkau <nbd@openwrt.org>
Date: Sat, 10 Oct 2009 19:25:48 +0000
Subject: gcc: add llvm-gcc and llvm from trunk (does not successfully compile
 a target yet, but gets close)

SVN-Revision: 18019
---
 toolchain/llvm/patches/110-darwin_version_detect.patch | 16 ++++++++++++++++
 1 file changed, 16 insertions(+)
 create mode 100644 toolchain/llvm/patches/110-darwin_version_detect.patch

(limited to 'toolchain/llvm/patches/110-darwin_version_detect.patch')

diff --git a/toolchain/llvm/patches/110-darwin_version_detect.patch b/toolchain/llvm/patches/110-darwin_version_detect.patch
new file mode 100644
index 0000000000..7fd62f93ee
--- /dev/null
+++ b/toolchain/llvm/patches/110-darwin_version_detect.patch
@@ -0,0 +1,16 @@
+--- a/Makefile.rules
++++ b/Makefile.rules
+@@ -506,11 +506,13 @@ endif
+ #--------------------------------------------------------------------
+ 
+ ifeq ($(HOST_OS),Darwin)
++  ifndef DARWIN_VERSION
+   DARWIN_VERSION := `sw_vers -productVersion`
+   # Strip a number like 10.4.7 to 10.4
+   DARWIN_VERSION := $(shell echo $(DARWIN_VERSION)| sed -E 's/(10.[0-9]).*/\1/')
+   # Get "4" out of 10.4 for later pieces in the makefile.
+   DARWIN_MAJVERS := $(shell echo $(DARWIN_VERSION)| sed -E 's/10.([0-9]).*/\1/')
++  endif
+ 
+   SharedLinkOptions=-Wl,-flat_namespace -Wl,-undefined -Wl,suppress \
+                     -dynamiclib
-- 
cgit v1.2.3