From ec7b663c86839b2ddc42b27fc472dfc1fbf0ebb8 Mon Sep 17 00:00:00 2001
From: Nicolas Thill <nico@openwrt.org>
Date: Wed, 21 Jan 2009 11:58:17 +0000
Subject: add support for gcc v4.3.1 & v4.3.2 (closes: #3479), thanks to Luigi
 Mantellini!

SVN-Revision: 14131
---
 tools/gmp/Makefile | 42 ++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 42 insertions(+)
 create mode 100644 tools/gmp/Makefile

(limited to 'tools/gmp')

diff --git a/tools/gmp/Makefile b/tools/gmp/Makefile
new file mode 100644
index 0000000000..42646716b5
--- /dev/null
+++ b/tools/gmp/Makefile
@@ -0,0 +1,42 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=gmp
+PKG_VERSION:=4.2.4
+
+PKG_SOURCE_URL:=@GNU/gmp/
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Build/Configure
+	(cd $(PKG_BUILD_DIR); \
+	./configure \
+	  --prefix=$(STAGING_DIR_HOST) \
+	  --build=$(GNU_HOST_NAME) \
+	  --enable-static \
+	  --disable-shared \
+	  --enable-cxx \
+	  --enable-mpbsd \
+	);
+endef
+
+define Build/Compile
+	make -C $(PKG_BUILD_DIR) all
+endef
+
+define Build/Install
+	make -C $(PKG_BUILD_DIR) install
+endef
+
+define Build/Clean
+	rm -rf $(PKG_BUILD_DIR)
+endef
+
+$(eval $(call HostBuild))
-- 
cgit v1.2.3