summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Castillo <joeycastillo@utexas.edu>2023-11-17 12:31:40 -0500
committerGitHub <noreply@github.com>2023-11-17 12:31:40 -0500
commit0263d9e0c7dfd9fc015f27bf3ae2487eaaa9d436 (patch)
treea8e2310f0f75a34e2088c3426385b4bf8d3ced02
parent67be6affd3367c4f6c302a57fdb35fc2bda50ce6 (diff)
parent7d353bba1c171e7885e69e88f314ca0dbe521863 (diff)
downloadSensor-Watch-0263d9e0c7dfd9fc015f27bf3ae2487eaaa9d436.tar.gz
Sensor-Watch-0263d9e0c7dfd9fc015f27bf3ae2487eaaa9d436.tar.bz2
Sensor-Watch-0263d9e0c7dfd9fc015f27bf3ae2487eaaa9d436.zip
Merge pull request #292 from WesleyAC/error-when-no-color
Don't allow building without setting board color.
-rw-r--r--.github/workflows/build.yml3
-rw-r--r--make.mk4
2 files changed, 7 insertions, 0 deletions
diff --git a/.github/workflows/build.yml b/.github/workflows/build.yml
index b150afb1..6b4fc793 100644
--- a/.github/workflows/build.yml
+++ b/.github/workflows/build.yml
@@ -6,6 +6,9 @@ on:
branches-ignore:
- gh-pages
+env:
+ COLOR: BLUE
+
jobs:
build:
container:
diff --git a/make.mk b/make.mk
index a83108bd..31189c8f 100644
--- a/make.mk
+++ b/make.mk
@@ -207,6 +207,10 @@ ifeq ($(LED), BLUE)
CFLAGS += -DWATCH_IS_BLUE_BOARD
endif
+ifndef COLOR
+$(error Set the COLOR variable to RED, BLUE, or GREEN depending on what board you have.)
+endif
+
ifeq ($(COLOR), BLUE)
CFLAGS += -DWATCH_IS_BLUE_BOARD
endif