summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoraustenadler <s5jitqluypqitf23ayssjtggxmafl4ti@fastmail.com>2023-07-29 11:25:27 +0000
committerGitHub <noreply@github.com>2023-07-29 07:25:27 -0400
commit340e5d1a4ad8d0028f3977c56af82def1544962d (patch)
tree4e53fe7b6b19e8e599d2862f3dcad92bfca16882
parent923112172d082105dd18a7dc3fe98dbb7e59b791 (diff)
downloadSensor-Watch-340e5d1a4ad8d0028f3977c56af82def1544962d.tar.gz
Sensor-Watch-340e5d1a4ad8d0028f3977c56af82def1544962d.tar.bz2
Sensor-Watch-340e5d1a4ad8d0028f3977c56af82def1544962d.zip
Fix lengthBytesUTF8 not a function (#255)
* Add lengthBytesUTF8 as an exported runtime method * Also export printErr as a runtime method --------- Co-authored-by: Austen Adler <agadler@austenadler.com>
-rw-r--r--rules.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/rules.mk b/rules.mk
index 2c4acec1..f04f3f46 100644
--- a/rules.mk
+++ b/rules.mk
@@ -18,6 +18,7 @@ $(BUILD)/$(BIN).html: $(OBJS)
@echo HTML $@
@$(CC) $(LDFLAGS) $(OBJS) $(LIBS) -o $@ \
-s ASYNCIFY=1 \
+ -s EXPORTED_RUNTIME_METHODS=lengthBytesUTF8,printErr \
-s EXPORTED_FUNCTIONS=_main \
--shell-file=$(TOP)/watch-library/simulator/shell.html