summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoey Castillo <jose.castillo@gmail.com>2021-10-23 16:13:11 -0400
committerJoey Castillo <jose.castillo@gmail.com>2021-10-23 16:13:11 -0400
commit8f6cd8b29062622095c489235061287f13e74dda (patch)
treec7087e2deae1c7b093b83d8ed8f6b9d7bf76057f
parentf1a706792e995f45b6b6f2ef70b2318253002249 (diff)
downloadSensor-Watch-8f6cd8b29062622095c489235061287f13e74dda.tar.gz
Sensor-Watch-8f6cd8b29062622095c489235061287f13e74dda.tar.bz2
Sensor-Watch-8f6cd8b29062622095c489235061287f13e74dda.zip
move weekday lookup to new utilities file
-rw-r--r--make.mk1
-rw-r--r--movement/watch_faces/clock/simple_clock_face.c15
-rw-r--r--watch-library/watch/watch_utility.c35
-rw-r--r--watch-library/watch/watch_utility.h41
4 files changed, 80 insertions, 12 deletions
diff --git a/make.mk b/make.mk
index 1c2a72f4..c9ef6534 100644
--- a/make.mk
+++ b/make.mk
@@ -81,6 +81,7 @@ SRCS += \
$(TOP)/watch-library/watch/watch_i2c.c \
$(TOP)/watch-library/watch/watch_uart.c \
$(TOP)/watch-library/watch/watch_deepsleep.c \
+ $(TOP)/watch-library/watch/watch_utility.c \
$(TOP)/watch-library/watch/watch_private.c \
$(TOP)/watch-library/watch/watch.c \
$(TOP)/watch-library/hal/src/hal_atomic.c \
diff --git a/movement/watch_faces/clock/simple_clock_face.c b/movement/watch_faces/clock/simple_clock_face.c
index e1e82031..9e279d95 100644
--- a/movement/watch_faces/clock/simple_clock_face.c
+++ b/movement/watch_faces/clock/simple_clock_face.c
@@ -1,6 +1,7 @@
#include <stdlib.h>
#include "simple_clock_face.h"
#include "watch.h"
+#include "watch_utility.h"
void simple_clock_face_setup(movement_settings_t *settings, void ** context_ptr) {
(void) settings;
@@ -19,7 +20,6 @@ void simple_clock_face_activate(movement_settings_t *settings, void *context) {
}
bool simple_clock_face_loop(movement_event_t event, movement_settings_t *settings, void *context) {
- const char weekdays[7][3] = {"SA", "SU", "MO", "TU", "WE", "TH", "FR"};
char buf[11];
uint8_t pos;
@@ -57,9 +57,9 @@ bool simple_clock_face_loop(movement_event_t event, movement_settings_t *setting
pos = 0;
if (event.event_type == EVENT_LOW_ENERGY_UPDATE) {
if (!watch_tick_animation_is_running()) watch_start_tick_animation(500);
- sprintf(buf, "%s%2d%2d%02d ", weekdays[simple_clock_face_get_weekday(date_time.unit.year, date_time.unit.month, date_time.unit.day)], date_time.unit.day, date_time.unit.hour, date_time.unit.minute);
+ sprintf(buf, "%s%2d%2d%02d ", watch_utility_get_weekday(date_time), date_time.unit.day, date_time.unit.hour, date_time.unit.minute);
} else {
- sprintf(buf, "%s%2d%2d%02d%02d", weekdays[simple_clock_face_get_weekday(date_time.unit.year, date_time.unit.month, date_time.unit.day)], date_time.unit.day, date_time.unit.hour, date_time.unit.minute, date_time.unit.second);
+ sprintf(buf, "%s%2d%2d%02d%02d", watch_utility_get_weekday(date_time), date_time.unit.day, date_time.unit.hour, date_time.unit.minute, date_time.unit.second);
}
}
watch_display_string(buf, pos);
@@ -83,12 +83,3 @@ void simple_clock_face_resign(movement_settings_t *settings, void *context) {
(void) settings;
(void) context;
}
-
-uint8_t simple_clock_face_get_weekday(uint16_t year, uint16_t month, uint16_t day) {
- year += 20;
- if (month <= 2) {
- month += 12;
- year--;
- }
- return (day + 13 * (month + 1) / 5 + year + year / 4 + 525) % 7;
-}
diff --git a/watch-library/watch/watch_utility.c b/watch-library/watch/watch_utility.c
new file mode 100644
index 00000000..a0f361b4
--- /dev/null
+++ b/watch-library/watch/watch_utility.c
@@ -0,0 +1,35 @@
+/*
+ * MIT License
+ *
+ * Copyright (c) 2021 Joey Castillo
+ *
+ * Permission is hereby granted, free of charge, to any person obtaining a copy
+ * of this software and associated documentation files (the "Software"), to deal
+ * in the Software without restriction, including without limitation the rights
+ * to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ * copies of the Software, and to permit persons to whom the Software is
+ * furnished to do so, subject to the following conditions:
+ *
+ * The above copyright notice and this permission notice shall be included in all
+ * copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ * AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ * OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ * SOFTWARE.
+ */
+
+#include "watch_utility.h"
+
+const char * watch_utility_get_weekday(watch_date_time date_time) {
+ static const char weekdays[7][3] = {"SA", "SU", "MO", "TU", "WE", "TH", "FR"};
+ date_time.unit.year += 20;
+ if (date_time.unit.month <= 2) {
+ date_time.unit.month += 12;
+ date_time.unit.year--;
+ }
+ return weekdays[(date_time.unit.day + 13 * (date_time.unit.month + 1) / 5 + date_time.unit.year + date_time.unit.year / 4 + 525) % 7];
+}
diff --git a/watch-library/watch/watch_utility.h b/watch-library/watch/watch_utility.h
new file mode 100644
index 00000000..e8808923
--- /dev/null
+++ b/watch-library/watch/watch_utility.h
@@ -0,0 +1,41 @@
+/*
+ * MIT License
+ *
+ * Copyright (c) 2021 Joey Castillo
+ *
+ * Permission is hereby granted, free of charge, to any person obtaining a copy
+ * of this software and associated documentation files (the "Software"), to deal
+ * in the Software without restriction, including without limitation the rights
+ * to use, copy, modify, merge, publish, distribute, sublicense, and/or sell
+ * copies of the Software, and to permit persons to whom the Software is
+ * furnished to do so, subject to the following conditions:
+ *
+ * The above copyright notice and this permission notice shall be included in all
+ * copies or substantial portions of the Software.
+ *
+ * THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND, EXPRESS OR
+ * IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF MERCHANTABILITY,
+ * FITNESS FOR A PARTICULAR PURPOSE AND NONINFRINGEMENT. IN NO EVENT SHALL THE
+ * AUTHORS OR COPYRIGHT HOLDERS BE LIABLE FOR ANY CLAIM, DAMAGES OR OTHER
+ * LIABILITY, WHETHER IN AN ACTION OF CONTRACT, TORT OR OTHERWISE, ARISING FROM,
+ * OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE
+ * SOFTWARE.
+ */
+
+#ifndef _WATCH_UTILITY_H_INCLUDED
+#define _WATCH_UTILITY_H_INCLUDED
+////< @file watch_utility.h
+
+#include "watch.h"
+
+/** @addtogroup utility Utility Functions
+ * @brief This section covers various useful functions that don't fit anywhere else.
+ **/
+/// @{
+/** @brief Returns a two-letter weekday for the given timestamp, suitable for display
+ * in positions 0-1 of the watch face
+ * @param date_time The watch_date_time whose weekday you want.
+ */
+const char * watch_utility_get_weekday(watch_date_time date_time);
+
+#endif