summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjoeycastillo <joeycastillo@utexas.edu>2022-11-22 08:37:33 -0600
committerGitHub <noreply@github.com>2022-11-22 08:37:33 -0600
commit8dbc00c56d8e2cc6618031d0c2a023d07a637cd3 (patch)
treeada5182417d8bd4628abb4231a99af1fbf83883c
parent2455a922c6c62dcb94106cef7214cf3f28c3ce55 (diff)
parentc5776781e0ed11ca9cfe3d72d5534d5209fcccac (diff)
downloadSensor-Watch-8dbc00c56d8e2cc6618031d0c2a023d07a637cd3.tar.gz
Sensor-Watch-8dbc00c56d8e2cc6618031d0c2a023d07a637cd3.tar.bz2
Sensor-Watch-8dbc00c56d8e2cc6618031d0c2a023d07a637cd3.zip
Merge pull request #118 from wryun/separate-emscripten-build-dir
Separate emscripten build directory
-rw-r--r--.github/workflows/build.yml4
-rw-r--r--.gitignore1
-rw-r--r--README.md2
-rw-r--r--make.mk4
-rwxr-xr-xmovement/make/make_alternate_fw.sh6
5 files changed, 11 insertions, 6 deletions
diff --git a/.github/workflows/build.yml b/.github/workflows/build.yml
index 3ed1ff26..b150afb1 100644
--- a/.github/workflows/build.yml
+++ b/.github/workflows/build.yml
@@ -44,7 +44,7 @@ jobs:
run: emmake make
working-directory: 'movement/make'
- name: Archive simulator build
- working-directory: 'movement/make/build'
+ working-directory: 'movement/make/build-sim'
run: |
cp watch.html index.html
tar -czf simulator.tar.gz index.html watch.wasm watch.js
@@ -52,4 +52,4 @@ jobs:
uses: actions/upload-artifact@v2
with:
name: simulator.tar.gz
- path: movement/make/build/simulator.tar.gz
+ path: movement/make/build-sim/simulator.tar.gz
diff --git a/.gitignore b/.gitignore
index 1100e911..06256b71 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
**/build/
+**/build-sim/
*.b#*
*.bin
*.d
diff --git a/README.md b/README.md
index 90ce5119..b2601da3 100644
--- a/README.md
+++ b/README.md
@@ -69,7 +69,7 @@ You may want to test out changes in the emulator first. To do this, you'll need
```
cd movement/make
emmake make
-python3 -m http.server 8000 -d build
+python3 -m http.server -d build-sim
```
Finally, visit [watch.html](http://localhost:8000/watch.html) to see your work.
diff --git a/make.mk b/make.mk
index 2fe89d75..446ad6fe 100644
--- a/make.mk
+++ b/make.mk
@@ -1,5 +1,9 @@
##############################################################################
+ifndef EMSCRIPTEN
BUILD = ./build
+else
+BUILD = ./build-sim
+endif
BIN = watch
ifndef BOARD
diff --git a/movement/make/make_alternate_fw.sh b/movement/make/make_alternate_fw.sh
index 575c9e52..739c8557 100755
--- a/movement/make/make_alternate_fw.sh
+++ b/movement/make/make_alternate_fw.sh
@@ -28,9 +28,9 @@ do
make clean
emmake make FIRMWARE=$VARIANT
mkdir "$sim_dir/$variant/"
- mv "build/watch.wasm" "$sim_dir/$variant/"
- mv "build/watch.js" "$sim_dir/$variant/"
- mv "build/watch.html" "$sim_dir/$variant/index.html"
+ mv "build-sim/watch.wasm" "$sim_dir/$variant/"
+ mv "build-sim/watch.js" "$sim_dir/$variant/"
+ mv "build-sim/watch.html" "$sim_dir/$variant/index.html"
done
echo "Done."