summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoey Castillo <joeycastillo@utexas.edu>2021-12-21 10:05:40 -0600
committerJoey Castillo <joeycastillo@utexas.edu>2021-12-21 10:05:40 -0600
commit4862472d1d8b9ea0bb8888965500f7372b4c5bfe (patch)
tree6f85d110163f7ea58f254aac7c649fc93d8eba1a
parent6256e709bf0e29444f6d5383897bc77acd242529 (diff)
parentb903c9665f0d975c60e248f6fb1c2cab0273d452 (diff)
downloadSensor-Watch-4862472d1d8b9ea0bb8888965500f7372b4c5bfe.tar.gz
Sensor-Watch-4862472d1d8b9ea0bb8888965500f7372b4c5bfe.tar.bz2
Sensor-Watch-4862472d1d8b9ea0bb8888965500f7372b4c5bfe.zip
Merge branch 'main' of github.com:joeycastillo/Sensor-Watch into main
-rw-r--r--.github/workflows/build.yml27
-rw-r--r--.github/workflows/gh-pages.yml21
-rw-r--r--.gitignore16
-rw-r--r--Doxyfile2
-rwxr-xr-xapps/accelerometer-test/Makefile (renamed from apps/accelerometer-test/make/Makefile)6
-rwxr-xr-xapps/accelerometer-test/make/.gitignore1
-rwxr-xr-xapps/beats-time/make/.gitignore1
-rwxr-xr-xapps/buzzer-test/make/.gitignore1
-rwxr-xr-xapps/spi-test/make/.gitignore1
-rwxr-xr-xapps/starter-project/Makefile (renamed from apps/starter-project/make/Makefile)22
-rwxr-xr-xapps/starter-project/make/.gitignore1
-rw-r--r--make.mk3
12 files changed, 74 insertions, 28 deletions
diff --git a/.github/workflows/build.yml b/.github/workflows/build.yml
new file mode 100644
index 00000000..1eab21fc
--- /dev/null
+++ b/.github/workflows/build.yml
@@ -0,0 +1,27 @@
+name: Build
+
+on:
+ pull_request:
+ push:
+ branches-ignore:
+ - gh-pages
+
+jobs:
+ build:
+ container:
+ image: ghcr.io/armmbed/mbed-os-env:latest
+ runs-on: ubuntu-latest
+ steps:
+ - name: Checkout
+ uses: actions/checkout@v2
+ - name: Compile starter-project app
+ run: make
+ working-directory: 'apps/starter-project'
+ - name: Compile accelerometer-test app
+ run: make
+ working-directory: 'apps/accelerometer-test'
+ - name: Upload UF2
+ uses: actions/upload-artifact@v2
+ with:
+ name: watch.uf2
+ path: apps/**/build/watch.uf2
diff --git a/.github/workflows/gh-pages.yml b/.github/workflows/gh-pages.yml
new file mode 100644
index 00000000..cab1c2d1
--- /dev/null
+++ b/.github/workflows/gh-pages.yml
@@ -0,0 +1,21 @@
+name: GitHub Pages
+
+on:
+ push:
+ branches:
+ - main
+
+jobs:
+ gh-pages:
+ runs-on: ubuntu-latest
+ steps:
+ - name: Checkout
+ uses: actions/checkout@v2
+ - name: Doxygen Action
+ uses: mattnotmitt/doxygen-action@v1
+ - name: Deploy
+ uses: peaceiris/actions-gh-pages@v3
+ with:
+ github_token: ${{ secrets.GITHUB_TOKEN }}
+ publish_branch: gh-pages
+ publish_dir: docs/
diff --git a/.gitignore b/.gitignore
index 4c97e2d4..1100e911 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,17 +1,19 @@
-.DS_Store
-*.s#*
+**/build/
*.b#*
-*.pro
-*.job
-
*.bin
+*.d
*.elf
*.hex
+*.job
*.lss
*.map
+*.o
+*.pro
+*.s#*
*.uf2
*srec
-*.o
-*.d
+.DS_Store
+.idea/
.vs
.vscode
+docs/ \ No newline at end of file
diff --git a/Doxyfile b/Doxyfile
index da710195..7f04a047 100644
--- a/Doxyfile
+++ b/Doxyfile
@@ -8,7 +8,7 @@ PROJECT_NAME = "Sensor Watch"
PROJECT_NUMBER = "0.0.0"
PROJECT_BRIEF = "A board replacement for the classic Casio F-91W wristwatch, powered by a Microchip SAM L22 microcontroller."
PROJECT_LOGO =
-OUTPUT_DIRECTORY = "../Sensor-Watch-Documentation"
+OUTPUT_DIRECTORY = "."
CREATE_SUBDIRS = NO
ALLOW_UNICODE_NAMES = NO
OUTPUT_LANGUAGE = English
diff --git a/apps/accelerometer-test/make/Makefile b/apps/accelerometer-test/Makefile
index c66ad20c..5534c178 100755
--- a/apps/accelerometer-test/make/Makefile
+++ b/apps/accelerometer-test/Makefile
@@ -1,10 +1,10 @@
-TOP = ../../..
+TOP = ../..
include $(TOP)/make.mk
INCLUDES += \
- -I../
+ -I./
SRCS += \
- ../app.c
+ ./app.c
include $(TOP)/rules.mk
diff --git a/apps/accelerometer-test/make/.gitignore b/apps/accelerometer-test/make/.gitignore
deleted file mode 100755
index 567609b1..00000000
--- a/apps/accelerometer-test/make/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-build/
diff --git a/apps/beats-time/make/.gitignore b/apps/beats-time/make/.gitignore
deleted file mode 100755
index 3722ac63..00000000
--- a/apps/beats-time/make/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-build/
diff --git a/apps/buzzer-test/make/.gitignore b/apps/buzzer-test/make/.gitignore
deleted file mode 100755
index 3722ac63..00000000
--- a/apps/buzzer-test/make/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-build/
diff --git a/apps/spi-test/make/.gitignore b/apps/spi-test/make/.gitignore
deleted file mode 100755
index 3722ac63..00000000
--- a/apps/spi-test/make/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-build/
diff --git a/apps/starter-project/make/Makefile b/apps/starter-project/Makefile
index 09a59a05..7cb3c48d 100755
--- a/apps/starter-project/make/Makefile
+++ b/apps/starter-project/Makefile
@@ -1,26 +1,26 @@
# Leave these lines at the top of the file.
# TOP should get us to the root of the project...
-TOP = ../../..
+TOP = ../..
# ...and make.mk has all the watch library sources and includes.
include $(TOP)/make.mk
-# If you add any other subdirectories with header files you wish to include, add them after ../
+# If you add any other subdirectories with header files you wish to include, add them after ./
# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
# INCLUDES += \
-# -I../ \
-# -I../drivers/ \
-# -I../utils/
+# -I./ \
+# -I drivers/ \
+# -I utils/
INCLUDES += \
- -I../ \
+ -I./ \
-# If you add any other source files you wish to compile, add them after ../app.c
+# If you add any other source files you wish to compile, add them after app.c
# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
# SRCS += \
-# ../app.c \
-# ../drivers/bmp280.c \
-# ../utils/temperature.c
+# ./app.c \
+# ./drivers/bmp280.c \
+# ./utils/temperature.c
SRCS += \
- ../app.c \
+ ./app.c \
# Leave this line at the bottom of the file; rules.mk has all the targets for making your project.
include $(TOP)/rules.mk
diff --git a/apps/starter-project/make/.gitignore b/apps/starter-project/make/.gitignore
deleted file mode 100755
index 3722ac63..00000000
--- a/apps/starter-project/make/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-build/
diff --git a/make.mk b/make.mk
index f6a37c7e..f1301733 100644
--- a/make.mk
+++ b/make.mk
@@ -20,7 +20,8 @@ else
MKDIR = mkdir
endif
-CFLAGS += -W -Wall --std=gnu99 -Os
+CFLAGS += -W -Wall -Wextra -Wmissing-prototypes -Wmissing-declarations
+CFLAGS += --std=gnu99 -Os
CFLAGS += -fno-diagnostics-show-caret
CFLAGS += -fdata-sections -ffunction-sections
CFLAGS += -funsigned-char -funsigned-bitfields