summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoey Castillo <joeycastillo@utexas.edu>2022-04-02 10:06:08 -0400
committerJoey Castillo <joeycastillo@utexas.edu>2022-04-02 10:07:18 -0400
commit51e357d8224e3d740f4ab9ed6d6fc0de4fdb9d4c (patch)
tree99b22bcc90182f494462096ce51c2b43723b1a82
parentfa0a424857fc3cdda56057f9e0201eaa30044489 (diff)
downloadSensor-Watch-51e357d8224e3d740f4ab9ed6d6fc0de4fdb9d4c.tar.gz
Sensor-Watch-51e357d8224e3d740f4ab9ed6d6fc0de4fdb9d4c.tar.bz2
Sensor-Watch-51e357d8224e3d740f4ab9ed6d6fc0de4fdb9d4c.zip
movement: final list of watch faces for stock firmware
-rw-r--r--make.mk1
-rw-r--r--movement/movement_config.h6
-rw-r--r--watch-library/simulator/watch/watch_adc.c2
3 files changed, 6 insertions, 3 deletions
diff --git a/make.mk b/make.mk
index 98e46c10..851e7e9b 100644
--- a/make.mk
+++ b/make.mk
@@ -161,6 +161,7 @@ SRCS += \
$(TOP)/watch-library/simulator/watch/watch_deepsleep.c \
$(TOP)/watch-library/simulator/watch/watch_private.c \
$(TOP)/watch-library/simulator/watch/watch.c \
+ $(TOP)/watch-library/shared/driver/thermistor_driver.c \
$(TOP)/watch-library/shared/watch/watch_private_buzzer.c \
$(TOP)/watch-library/shared/watch/watch_private_display.c \
$(TOP)/watch-library/shared/watch/watch_utility.c \
diff --git a/movement/movement_config.h b/movement/movement_config.h
index e68fcc9a..94456776 100644
--- a/movement/movement_config.h
+++ b/movement/movement_config.h
@@ -29,8 +29,10 @@
const watch_face_t watch_faces[] = {
simple_clock_face,
- beats_face,
- voltage_face,
+ world_clock_face,
+ sunrise_sunset_face,
+ moon_phase_face,
+ thermistor_readout_face,
preferences_face,
set_time_face,
};
diff --git a/watch-library/simulator/watch/watch_adc.c b/watch-library/simulator/watch/watch_adc.c
index 364e2119..b03d68cb 100644
--- a/watch-library/simulator/watch/watch_adc.c
+++ b/watch-library/simulator/watch/watch_adc.c
@@ -29,7 +29,7 @@ void watch_enable_adc(void) {}
void watch_enable_analog_input(const uint8_t pin) {}
uint16_t watch_get_analog_pin_level(const uint8_t pin) {
- return 0;
+ return 32767; // pretend it's half of VCC
}
void watch_set_analog_num_samples(uint16_t samples) {}