diff options
author | Joey Castillo <jose.castillo@gmail.com> | 2021-08-02 13:48:35 -0400 |
---|---|---|
committer | Joey Castillo <jose.castillo@gmail.com> | 2021-08-02 14:36:04 -0400 |
commit | 34945d78e933fc62bedcc975e88be02a0b7fcc2e (patch) | |
tree | 317edc18fe08d76a1f5d8c3aabf88cf58ba73897 /Sensor Watch Starter Project/make | |
parent | 2d1e2e8c76623543817f4c62b26fc300c1fd0d2c (diff) | |
download | Sensor-Watch-34945d78e933fc62bedcc975e88be02a0b7fcc2e.tar.gz Sensor-Watch-34945d78e933fc62bedcc975e88be02a0b7fcc2e.tar.bz2 Sensor-Watch-34945d78e933fc62bedcc975e88be02a0b7fcc2e.zip |
major project reorg, move library one level up
Diffstat (limited to 'Sensor Watch Starter Project/make')
-rwxr-xr-x | Sensor Watch Starter Project/make/Makefile | 146 | ||||
-rw-r--r-- | Sensor Watch Starter Project/make/uf2conv.py | 302 |
2 files changed, 75 insertions, 373 deletions
diff --git a/Sensor Watch Starter Project/make/Makefile b/Sensor Watch Starter Project/make/Makefile index a40eb7ca..5f811620 100755 --- a/Sensor Watch Starter Project/make/Makefile +++ b/Sensor Watch Starter Project/make/Makefile @@ -8,7 +8,7 @@ BIN = watch CC = arm-none-eabi-gcc
OBJCOPY = arm-none-eabi-objcopy
SIZE = arm-none-eabi-size
-UF2 = python uf2conv.py
+UF2 = python ../../utils/uf2conv.py
ifeq ($(OS), Windows_NT)
MKDIR = gmkdir
@@ -25,79 +25,83 @@ CFLAGS += -MD -MP -MT $(BUILD)/$(*F).o -MF $(BUILD)/$(@F).d LDFLAGS += -mcpu=cortex-m0plus -mthumb
LDFLAGS += -Wl,--gc-sections
-LDFLAGS += -Wl,--script=../linker/saml22j18.ld
+LDFLAGS += -Wl,--script=../../watch-library/linker/saml22j18.ld
+# If you add any additional directories with headers, add them to this list, e.g.
+# ../drivers/
INCLUDES += \
- -I../include \
- -I../hal/ \
- -I../hal/documentation/ \
- -I../hal/include/ \
- -I../hal/src/ \
- -I../hal/utils/ \
- -I../hal/utils/include/ \
- -I../hal/utils/src/ \
- -I../hpl/ \
- -I../hpl/adc/ \
- -I../hpl/core/ \
- -I../hpl/dmac/ \
- -I../hpl/eic/ \
- -I../hpl/gclk/ \
- -I../hpl/mclk/ \
- -I../hpl/osc32kctrl/ \
- -I../hpl/oscctrl/ \
- -I../hpl/pm/ \
- -I../hpl/port/ \
- -I../hpl/rtc/ \
- -I../hpl/sercom/ \
- -I../hpl/slcd/ \
- -I../hpl/systick/ \
- -I../hpl/tcc/ \
- -I../hpl/tc/ \
- -I../hri/ \
- -I../config/ \
- -I../hw/ \
- -I../watch/ \
- -I../app/ \
- -I..
-
+ -I../ \
+ -I../../watch-library/include \
+ -I../../watch-library/hal/ \
+ -I../../watch-library/hal/documentation/ \
+ -I../../watch-library/hal/include/ \
+ -I../../watch-library/hal/src/ \
+ -I../../watch-library/hal/utils/ \
+ -I../../watch-library/hal/utils/include/ \
+ -I../../watch-library/hal/utils/src/ \
+ -I../../watch-library/hpl/ \
+ -I../../watch-library/hpl/adc/ \
+ -I../../watch-library/hpl/core/ \
+ -I../../watch-library/hpl/dmac/ \
+ -I../../watch-library/hpl/eic/ \
+ -I../../watch-library/hpl/gclk/ \
+ -I../../watch-library/hpl/mclk/ \
+ -I../../watch-library/hpl/osc32kctrl/ \
+ -I../../watch-library/hpl/oscctrl/ \
+ -I../../watch-library/hpl/pm/ \
+ -I../../watch-library/hpl/port/ \
+ -I../../watch-library/hpl/rtc/ \
+ -I../../watch-library/hpl/sercom/ \
+ -I../../watch-library/hpl/slcd/ \
+ -I../../watch-library/hpl/systick/ \
+ -I../../watch-library/hpl/tcc/ \
+ -I../../watch-library/hpl/tc/ \
+ -I../../watch-library/hri/ \
+ -I../../watch-library/config/ \
+ -I../../watch-library/hw/ \
+ -I../../watch-library/watch/ \
+ -I../../watch-library
+
+# If you add any additional C files to your project, add them each to this list, e.g.
+# ../drivers/st25dv.c
SRCS += \
- ../main.c \
- ../startup_saml22.c \
- ../hw/driver_init.c \
- ../watch/watch.c \
- ../app/app.c \
- ../hal/src/hal_adc_sync.c \
- ../hal/src/hal_atomic.c \
- ../hal/src/hal_calendar.c \
- ../hal/src/hal_delay.c \
- ../hal/src/hal_ext_irq.c \
- ../hal/src/hal_gpio.c \
- ../hal/src/hal_i2c_m_sync.c \
- ../hal/src/hal_init.c \
- ../hal/src/hal_io.c \
- ../hal/src/hal_pwm.c \
- ../hal/src/hal_slcd_sync.c \
- ../hal/src/hal_sleep.c \
- ../hal/utils/src/utils_assert.c \
- ../hal/utils/src/utils_event.c \
- ../hal/utils/src/utils_list.c \
- ../hal/utils/src/utils_syscalls.c \
- ../hpl/adc/hpl_adc.c \
- ../hpl/core/hpl_core_m0plus_base.c \
- ../hpl/core/hpl_init.c \
- ../hpl/dmac/hpl_dmac.c \
- ../hpl/eic/hpl_eic.c \
- ../hpl/gclk/hpl_gclk.c \
- ../hpl/mclk/hpl_mclk.c \
- ../hpl/osc32kctrl/hpl_osc32kctrl.c \
- ../hpl/oscctrl/hpl_oscctrl.c \
- ../hpl/pm/hpl_pm.c \
- ../hpl/rtc/hpl_rtc.c \
- ../hpl/sercom/hpl_sercom.c \
- ../hpl/slcd/hpl_slcd.c \
- ../hpl/systick/hpl_systick.c \
- ../hpl/tcc/hpl_tcc.c \
- ../hpl/tc/hpl_tc.c
+ ../app.c \
+ ../../watch-library/main.c \
+ ../../watch-library/startup_saml22.c \
+ ../../watch-library/hw/driver_init.c \
+ ../../watch-library/watch/watch.c \
+ ../../watch-library/hal/src/hal_adc_sync.c \
+ ../../watch-library/hal/src/hal_atomic.c \
+ ../../watch-library/hal/src/hal_calendar.c \
+ ../../watch-library/hal/src/hal_delay.c \
+ ../../watch-library/hal/src/hal_ext_irq.c \
+ ../../watch-library/hal/src/hal_gpio.c \
+ ../../watch-library/hal/src/hal_i2c_m_sync.c \
+ ../../watch-library/hal/src/hal_init.c \
+ ../../watch-library/hal/src/hal_io.c \
+ ../../watch-library/hal/src/hal_pwm.c \
+ ../../watch-library/hal/src/hal_slcd_sync.c \
+ ../../watch-library/hal/src/hal_sleep.c \
+ ../../watch-library/hal/utils/src/utils_assert.c \
+ ../../watch-library/hal/utils/src/utils_event.c \
+ ../../watch-library/hal/utils/src/utils_list.c \
+ ../../watch-library/hal/utils/src/utils_syscalls.c \
+ ../../watch-library/hpl/adc/hpl_adc.c \
+ ../../watch-library/hpl/core/hpl_core_m0plus_base.c \
+ ../../watch-library/hpl/core/hpl_init.c \
+ ../../watch-library/hpl/dmac/hpl_dmac.c \
+ ../../watch-library/hpl/eic/hpl_eic.c \
+ ../../watch-library/hpl/gclk/hpl_gclk.c \
+ ../../watch-library/hpl/mclk/hpl_mclk.c \
+ ../../watch-library/hpl/osc32kctrl/hpl_osc32kctrl.c \
+ ../../watch-library/hpl/oscctrl/hpl_oscctrl.c \
+ ../../watch-library/hpl/pm/hpl_pm.c \
+ ../../watch-library/hpl/rtc/hpl_rtc.c \
+ ../../watch-library/hpl/sercom/hpl_sercom.c \
+ ../../watch-library/hpl/slcd/hpl_slcd.c \
+ ../../watch-library/hpl/systick/hpl_systick.c \
+ ../../watch-library/hpl/tcc/hpl_tcc.c \
+ ../../watch-library/hpl/tc/hpl_tc.c
DEFINES += \
-D__SAML22J18A__ \
diff --git a/Sensor Watch Starter Project/make/uf2conv.py b/Sensor Watch Starter Project/make/uf2conv.py deleted file mode 100644 index 849e6499..00000000 --- a/Sensor Watch Starter Project/make/uf2conv.py +++ /dev/null @@ -1,302 +0,0 @@ -#!/usr/bin/env python3 -import sys -import struct -import subprocess -import re -import os -import os.path -import argparse - - -UF2_MAGIC_START0 = 0x0A324655 # "UF2\n" -UF2_MAGIC_START1 = 0x9E5D5157 # Randomly selected -UF2_MAGIC_END = 0x0AB16F30 # Ditto - -families = { - 'SAMD21': 0x68ed2b88, - 'SAML21': 0x1851780a, - 'SAML22': 0x2c29472f, - 'SAMD51': 0x55114460, - 'NRF52': 0x1b57745f, - 'STM32F1': 0x5ee21072, - 'STM32F4': 0x57755a57, - 'ATMEGA32': 0x16573617, - 'MIMXRT10XX': 0x4FB2D5BD -} - -INFO_FILE = "/INFO_UF2.TXT" - -appstartaddr = 0x2000 -familyid = 0x0 - - -def is_uf2(buf): - w = struct.unpack("<II", buf[0:8]) - return w[0] == UF2_MAGIC_START0 and w[1] == UF2_MAGIC_START1 - -def is_hex(buf): - try: - w = buf[0:30].decode("utf-8") - except UnicodeDecodeError: - return False - if w[0] == ':' and re.match(b"^[:0-9a-fA-F\r\n]+$", buf): - return True - return False - -def convert_from_uf2(buf): - global appstartaddr - numblocks = len(buf) // 512 - curraddr = None - outp = b"" - for blockno in range(numblocks): - ptr = blockno * 512 - block = buf[ptr:ptr + 512] - hd = struct.unpack(b"<IIIIIIII", block[0:32]) - if hd[0] != UF2_MAGIC_START0 or hd[1] != UF2_MAGIC_START1: - print("Skipping block at " + ptr + "; bad magic") - continue - if hd[2] & 1: - # NO-flash flag set; skip block - continue - datalen = hd[4] - if datalen > 476: - assert False, "Invalid UF2 data size at " + ptr - newaddr = hd[3] - if curraddr == None: - appstartaddr = newaddr - curraddr = newaddr - padding = newaddr - curraddr - if padding < 0: - assert False, "Block out of order at " + ptr - if padding > 10*1024*1024: - assert False, "More than 10M of padding needed at " + ptr - if padding % 4 != 0: - assert False, "Non-word padding size at " + ptr - while padding > 0: - padding -= 4 - outp += b"\x00\x00\x00\x00" - outp += block[32 : 32 + datalen] - curraddr = newaddr + datalen - return outp - -def convert_to_carray(file_content): - outp = "const unsigned char bindata[] __attribute__((aligned(16))) = {" - for i in range(len(file_content)): - if i % 16 == 0: - outp += "\n" - outp += "0x%02x, " % ord(file_content[i]) - outp += "\n};\n" - return outp - -def convert_to_uf2(file_content): - global familyid - datapadding = b"" - while len(datapadding) < 512 - 256 - 32 - 4: - datapadding += b"\x00\x00\x00\x00" - numblocks = (len(file_content) + 255) // 256 - outp = b"" - for blockno in range(numblocks): - ptr = 256 * blockno - chunk = file_content[ptr:ptr + 256] - flags = 0x0 - if familyid: - flags |= 0x2000 - hd = struct.pack(b"<IIIIIIII", - UF2_MAGIC_START0, UF2_MAGIC_START1, - flags, ptr + appstartaddr, 256, blockno, numblocks, familyid) - while len(chunk) < 256: - chunk += b"\x00" - block = hd + chunk + datapadding + struct.pack(b"<I", UF2_MAGIC_END) - assert len(block) == 512 - outp += block - return outp - -class Block: - def __init__(self, addr): - self.addr = addr - self.bytes = bytearray(256) - - def encode(self, blockno, numblocks): - global familyid - flags = 0x0 - if familyid: - flags |= 0x2000 - hd = struct.pack("<IIIIIIII", - UF2_MAGIC_START0, UF2_MAGIC_START1, - flags, self.addr, 256, blockno, numblocks, familyid) - hd += self.bytes[0:256] - while len(hd) < 512 - 4: - hd += b"\x00" - hd += struct.pack("<I", UF2_MAGIC_END) - return hd - -def convert_from_hex_to_uf2(buf): - global appstartaddr - appstartaddr = None - upper = 0 - currblock = None - blocks = [] - for line in buf.split('\n'): - if line[0] != ":": - continue - i = 1 - rec = [] - while i < len(line) - 1: - rec.append(int(line[i:i+2], 16)) - i += 2 - tp = rec[3] - if tp == 4: - upper = ((rec[4] << 8) | rec[5]) << 16 - elif tp == 2: - upper = ((rec[4] << 8) | rec[5]) << 4 - assert (upper & 0xffff) == 0 - elif tp == 1: - break - elif tp == 0: - addr = upper | (rec[1] << 8) | rec[2] - if appstartaddr == None: - appstartaddr = addr - i = 4 - while i < len(rec) - 1: - if not currblock or currblock.addr & ~0xff != addr & ~0xff: - currblock = Block(addr & ~0xff) - blocks.append(currblock) - currblock.bytes[addr & 0xff] = rec[i] - addr += 1 - i += 1 - numblocks = len(blocks) - resfile = b"" - for i in range(0, numblocks): - resfile += blocks[i].encode(i, numblocks) - return resfile - -def to_str(b): - return b.decode("utf-8") - -def get_drives(): - drives = [] - if sys.platform == "win32": - r = subprocess.check_output(["wmic", "PATH", "Win32_LogicalDisk", - "get", "DeviceID,", "VolumeName,", - "FileSystem,", "DriveType"]) - for line in to_str(r).split('\n'): - words = re.split('\s+', line) - if len(words) >= 3 and words[1] == "2" and words[2] == "FAT": - drives.append(words[0]) - else: - rootpath = "/media" - if sys.platform == "darwin": - rootpath = "/Volumes" - elif sys.platform == "linux": - tmp = rootpath + "/" + os.environ["USER"] - if os.path.isdir(tmp): - rootpath = tmp - for d in os.listdir(rootpath): - drives.append(os.path.join(rootpath, d)) - - - def has_info(d): - try: - return os.path.isfile(d + INFO_FILE) - except: - return False - - return list(filter(has_info, drives)) - - -def board_id(path): - with open(path + INFO_FILE, mode='r') as file: - file_content = file.read() - return re.search("Board-ID: ([^\r\n]*)", file_content).group(1) - - -def list_drives(): - for d in get_drives(): - print(d, board_id(d)) - - -def write_file(name, buf): - with open(name, "wb") as f: - f.write(buf) - print("Wrote %d bytes to %s" % (len(buf), name)) - - -def main(): - global appstartaddr, familyid - def error(msg): - print(msg) - sys.exit(1) - parser = argparse.ArgumentParser(description='Convert to UF2 or flash directly.') - parser.add_argument('input', metavar='INPUT', type=str, nargs='?', - help='input file (HEX, BIN or UF2)') - parser.add_argument('-b' , '--base', dest='base', type=str, - default="0x2000", - help='set base address of application for BIN format (default: 0x2000)') - parser.add_argument('-o' , '--output', metavar="FILE", dest='output', type=str, - help='write output to named file; defaults to "flash.uf2" or "flash.bin" where sensible') - parser.add_argument('-d' , '--device', dest="device_path", - help='select a device path to flash') - parser.add_argument('-l' , '--list', action='store_true', - help='list connected devices') - parser.add_argument('-c' , '--convert', action='store_true', - help='do not flash, just convert') - parser.add_argument('-D' , '--deploy', action='store_true', - help='just flash, do not convert') - parser.add_argument('-f' , '--family', dest='family', type=str, - default="0x0", - help='specify familyID - number or name (default: 0x0)') - parser.add_argument('-C' , '--carray', action='store_true', - help='convert binary file to a C array, not UF2') - args = parser.parse_args() - appstartaddr = int(args.base, 0) - - if args.family.upper() in families: - familyid = families[args.family.upper()] - else: - try: - familyid = int(args.family, 0) - except ValueError: - error("Family ID needs to be a number or one of: " + ", ".join(families.keys())) - - if args.list: - list_drives() - else: - if not args.input: - error("Need input file") - with open(args.input, mode='rb') as f: - inpbuf = f.read() - from_uf2 = is_uf2(inpbuf) - ext = "uf2" - if args.deploy: - outbuf = inpbuf - elif from_uf2: - outbuf = convert_from_uf2(inpbuf) - ext = "bin" - elif is_hex(inpbuf): - outbuf = convert_from_hex_to_uf2(inpbuf.decode("utf-8")) - elif args.carray: - outbuf = convert_to_carray(inpbuf) - ext = "h" - else: - outbuf = convert_to_uf2(inpbuf) - print("Converting to %s, output size: %d, start address: 0x%x" % - (ext, len(outbuf), appstartaddr)) - if args.convert or ext != "uf2": - drives = [] - if args.output == None: - args.output = "flash." + ext - else: - drives = get_drives() - - if args.output: - write_file(args.output, outbuf) - else: - if len(drives) == 0: - error("No drive to deploy.") - for d in drives: - print("Flashing %s (%s)" % (d, board_id(d))) - write_file(d + "/NEW.UF2", outbuf) - - -if __name__ == "__main__": - main() |