summaryrefslogtreecommitdiffstats
path: root/apps/Sensor Watch BME280 Project/make
diff options
context:
space:
mode:
authorJoey Castillo <jose.castillo@gmail.com>2021-09-16 15:40:01 -0400
committerJoey Castillo <jose.castillo@gmail.com>2021-09-16 15:40:01 -0400
commit07420e6ead840973d7136222b8e872261a7b18b8 (patch)
tree72c8af88f945c0d4f8b2a3b467994ccc8cc7bfd8 /apps/Sensor Watch BME280 Project/make
parentb3de08343b7db4ed380cdfa3ca0df824728999b1 (diff)
downloadSensor-Watch-07420e6ead840973d7136222b8e872261a7b18b8.tar.gz
Sensor-Watch-07420e6ead840973d7136222b8e872261a7b18b8.tar.bz2
Sensor-Watch-07420e6ead840973d7136222b8e872261a7b18b8.zip
move apps to subdirectory, add relative path support to Makefile
Diffstat (limited to 'apps/Sensor Watch BME280 Project/make')
-rwxr-xr-xapps/Sensor Watch BME280 Project/make/.gitignore1
-rwxr-xr-xapps/Sensor Watch BME280 Project/make/Makefile10
2 files changed, 11 insertions, 0 deletions
diff --git a/apps/Sensor Watch BME280 Project/make/.gitignore b/apps/Sensor Watch BME280 Project/make/.gitignore
new file mode 100755
index 00000000..3722ac63
--- /dev/null
+++ b/apps/Sensor Watch BME280 Project/make/.gitignore
@@ -0,0 +1 @@
+build/
diff --git a/apps/Sensor Watch BME280 Project/make/Makefile b/apps/Sensor Watch BME280 Project/make/Makefile
new file mode 100755
index 00000000..c66ad20c
--- /dev/null
+++ b/apps/Sensor Watch BME280 Project/make/Makefile
@@ -0,0 +1,10 @@
+TOP = ../../..
+include $(TOP)/make.mk
+
+INCLUDES += \
+ -I../
+
+SRCS += \
+ ../app.c
+
+include $(TOP)/rules.mk