summaryrefslogtreecommitdiffstats
path: root/apps/Sensor Watch SPI Test
diff options
context:
space:
mode:
authorJoey Castillo <joeycastillo@utexas.edu>2021-12-05 23:06:25 -0600
committerJoey Castillo <joeycastillo@utexas.edu>2021-12-10 11:54:16 -0500
commit316e1f292c603885f2af3dcd69ce797d64776425 (patch)
tree96eeba3e256e49ec6393a39767098e3975426454 /apps/Sensor Watch SPI Test
parent616587a2030be054277ef74fdbf0be626684db3c (diff)
downloadSensor-Watch-316e1f292c603885f2af3dcd69ce797d64776425.tar.gz
Sensor-Watch-316e1f292c603885f2af3dcd69ce797d64776425.tar.bz2
Sensor-Watch-316e1f292c603885f2af3dcd69ce797d64776425.zip
rename project files
Diffstat (limited to 'apps/Sensor Watch SPI Test')
-rw-r--r--apps/Sensor Watch SPI Test/app.c71
-rwxr-xr-xapps/Sensor Watch SPI Test/make/.gitignore1
-rwxr-xr-xapps/Sensor Watch SPI Test/make/Makefile10
3 files changed, 0 insertions, 82 deletions
diff --git a/apps/Sensor Watch SPI Test/app.c b/apps/Sensor Watch SPI Test/app.c
deleted file mode 100644
index 3fba9386..00000000
--- a/apps/Sensor Watch SPI Test/app.c
+++ /dev/null
@@ -1,71 +0,0 @@
-#include <stdio.h>
-#include <string.h>
-#include <peripheral_clk_config.h>
-#include "watch.h"
-
-// NOTE: as of this writing (10/25/21) there is no SPI controller functionality in the watch library.
-// this is a very basic app to confirm that SPI is working, tested with board OSO-MISC-21-001 and a GD25Q16C Flash chip.
-// The updated SPI Flash sensor board design is OSO-MISC-21-017 (it's easier to build, 0603 passives instead of 0402's).
-
-struct io_descriptor *io;
-struct spi_m_sync_descriptor SPI_0;
-
-void app_init() {
- // SPI_0_CLOCK_init
- hri_gclk_write_PCHCTRL_reg(GCLK, SERCOM3_GCLK_ID_CORE, CONF_GCLK_SERCOM3_CORE_SRC | (1 << GCLK_PCHCTRL_CHEN_Pos));
- hri_gclk_write_PCHCTRL_reg(GCLK, SERCOM3_GCLK_ID_SLOW, CONF_GCLK_SERCOM3_SLOW_SRC | (1 << GCLK_PCHCTRL_CHEN_Pos));
- hri_mclk_set_APBCMASK_SERCOM3_bit(MCLK);
-
- spi_m_sync_init(&SPI_0, SERCOM3);
-
- // SPI_0_PORT_init
- gpio_set_pin_level(A3, true);
- gpio_set_pin_direction(A3, GPIO_DIRECTION_OUT);
- gpio_set_pin_function(A3, GPIO_PIN_FUNCTION_OFF);
-
- gpio_set_pin_level(A2, false);
- gpio_set_pin_direction(A2, GPIO_DIRECTION_OUT);
- gpio_set_pin_function(A2, PINMUX_PB02C_SERCOM3_PAD0);
-
- gpio_set_pin_direction(A4, GPIO_DIRECTION_IN);
- gpio_set_pin_pull_mode(A4, GPIO_PULL_OFF);
- gpio_set_pin_function(A4, PINMUX_PB00C_SERCOM3_PAD2);
-
- gpio_set_pin_level(A1, false);
- gpio_set_pin_direction(A1, GPIO_DIRECTION_OUT);
- gpio_set_pin_function(A1, PINMUX_PB01C_SERCOM3_PAD3);
-
- spi_m_sync_get_io_descriptor(&SPI_0, &io);
- spi_m_sync_enable(&SPI_0);
-}
-
-void app_wake_from_backup() {
-}
-
-void app_setup() {
-}
-
-void app_prepare_for_standby() {
-}
-
-void app_wake_from_standby() {
-}
-
-static uint8_t get_id_command[4] = {0x9F};
-
-bool app_loop() {
- watch_set_pin_level(A3, false);
- io_write(io, get_id_command, 1);
- uint8_t buf[3] = {0};
-
- // should print 0, 0, 0
- printf("blank: %x, %x, %x\n", buf[0], buf[1], buf[2]);
- io_read(io, buf, 3);
- watch_set_pin_level(A3, true);
- // should print c8, 40, 15
- printf("ident: %x, %x, %x\n", buf[0], buf[1], buf[2]);
-
- delay_ms(100);
-
- return false;
-}
diff --git a/apps/Sensor Watch SPI Test/make/.gitignore b/apps/Sensor Watch SPI Test/make/.gitignore
deleted file mode 100755
index 3722ac63..00000000
--- a/apps/Sensor Watch SPI Test/make/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-build/
diff --git a/apps/Sensor Watch SPI Test/make/Makefile b/apps/Sensor Watch SPI Test/make/Makefile
deleted file mode 100755
index c66ad20c..00000000
--- a/apps/Sensor Watch SPI Test/make/Makefile
+++ /dev/null
@@ -1,10 +0,0 @@
-TOP = ../../..
-include $(TOP)/make.mk
-
-INCLUDES += \
- -I../
-
-SRCS += \
- ../app.c
-
-include $(TOP)/rules.mk