summaryrefslogtreecommitdiffstats
path: root/apps/starter-project
diff options
context:
space:
mode:
authorJoey Castillo <joeycastillo@utexas.edu>2022-01-04 15:38:42 -0500
committerJoey Castillo <joeycastillo@utexas.edu>2022-01-04 15:38:42 -0500
commitc5ecf1dabdc66818892f37f37bf75cb39d93b5f7 (patch)
treedd054cdb73b1dee7f4c34f43f50b2711fec35f8e /apps/starter-project
parent16ac7534c4f5f0b13c2609c26a139e6df3139170 (diff)
parent311cfdb5f45cab25053d7a188a2eb30e2c5e781b (diff)
downloadSensor-Watch-c5ecf1dabdc66818892f37f37bf75cb39d93b5f7.tar.gz
Sensor-Watch-c5ecf1dabdc66818892f37f37bf75cb39d93b5f7.tar.bz2
Sensor-Watch-c5ecf1dabdc66818892f37f37bf75cb39d93b5f7.zip
Merge branch 'main' of https://github.com/joeycastillo/Sensor-Watch into main
Diffstat (limited to 'apps/starter-project')
-rwxr-xr-xapps/starter-project/Makefile (renamed from apps/starter-project/make/Makefile)22
-rwxr-xr-xapps/starter-project/make/.gitignore1
2 files changed, 11 insertions, 12 deletions
diff --git a/apps/starter-project/make/Makefile b/apps/starter-project/Makefile
index 09a59a05..7cb3c48d 100755
--- a/apps/starter-project/make/Makefile
+++ b/apps/starter-project/Makefile
@@ -1,26 +1,26 @@
# Leave these lines at the top of the file.
# TOP should get us to the root of the project...
-TOP = ../../..
+TOP = ../..
# ...and make.mk has all the watch library sources and includes.
include $(TOP)/make.mk
-# If you add any other subdirectories with header files you wish to include, add them after ../
+# If you add any other subdirectories with header files you wish to include, add them after ./
# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
# INCLUDES += \
-# -I../ \
-# -I../drivers/ \
-# -I../utils/
+# -I./ \
+# -I drivers/ \
+# -I utils/
INCLUDES += \
- -I../ \
+ -I./ \
-# If you add any other source files you wish to compile, add them after ../app.c
+# If you add any other source files you wish to compile, add them after app.c
# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
# SRCS += \
-# ../app.c \
-# ../drivers/bmp280.c \
-# ../utils/temperature.c
+# ./app.c \
+# ./drivers/bmp280.c \
+# ./utils/temperature.c
SRCS += \
- ../app.c \
+ ./app.c \
# Leave this line at the bottom of the file; rules.mk has all the targets for making your project.
include $(TOP)/rules.mk
diff --git a/apps/starter-project/make/.gitignore b/apps/starter-project/make/.gitignore
deleted file mode 100755
index 3722ac63..00000000
--- a/apps/starter-project/make/.gitignore
+++ /dev/null
@@ -1 +0,0 @@
-build/