summaryrefslogtreecommitdiffstats
path: root/apps
diff options
context:
space:
mode:
authorWillian Paixao <willian@ufpa.br>2021-12-11 20:33:58 +0100
committerWillian Paixao <willian@ufpa.br>2021-12-11 20:33:58 +0100
commitd46cc407dfec340606ab4d5841a79b3571ee122a (patch)
tree6b62dcbdf6e5a6866d784522e0a677fb3f5e156e /apps
parent095466c27046cbe88925ceedf5cb2c1c550c8008 (diff)
downloadSensor-Watch-d46cc407dfec340606ab4d5841a79b3571ee122a.tar.gz
Sensor-Watch-d46cc407dfec340606ab4d5841a79b3571ee122a.tar.bz2
Sensor-Watch-d46cc407dfec340606ab4d5841a79b3571ee122a.zip
update makefile and pipeline workflow
Diffstat (limited to 'apps')
-rwxr-xr-xapps/accelerometer-test/Makefile (renamed from apps/accelerometer-test/make/Makefile)6
-rwxr-xr-xapps/starter-project/Makefile (renamed from apps/starter-project/make/Makefile)22
2 files changed, 14 insertions, 14 deletions
diff --git a/apps/accelerometer-test/make/Makefile b/apps/accelerometer-test/Makefile
index c66ad20c..5534c178 100755
--- a/apps/accelerometer-test/make/Makefile
+++ b/apps/accelerometer-test/Makefile
@@ -1,10 +1,10 @@
-TOP = ../../..
+TOP = ../..
include $(TOP)/make.mk
INCLUDES += \
- -I../
+ -I./
SRCS += \
- ../app.c
+ ./app.c
include $(TOP)/rules.mk
diff --git a/apps/starter-project/make/Makefile b/apps/starter-project/Makefile
index 09a59a05..7cb3c48d 100755
--- a/apps/starter-project/make/Makefile
+++ b/apps/starter-project/Makefile
@@ -1,26 +1,26 @@
# Leave these lines at the top of the file.
# TOP should get us to the root of the project...
-TOP = ../../..
+TOP = ../..
# ...and make.mk has all the watch library sources and includes.
include $(TOP)/make.mk
-# If you add any other subdirectories with header files you wish to include, add them after ../
+# If you add any other subdirectories with header files you wish to include, add them after ./
# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
# INCLUDES += \
-# -I../ \
-# -I../drivers/ \
-# -I../utils/
+# -I./ \
+# -I drivers/ \
+# -I utils/
INCLUDES += \
- -I../ \
+ -I./ \
-# If you add any other source files you wish to compile, add them after ../app.c
+# If you add any other source files you wish to compile, add them after app.c
# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
# SRCS += \
-# ../app.c \
-# ../drivers/bmp280.c \
-# ../utils/temperature.c
+# ./app.c \
+# ./drivers/bmp280.c \
+# ./utils/temperature.c
SRCS += \
- ../app.c \
+ ./app.c \
# Leave this line at the bottom of the file; rules.mk has all the targets for making your project.
include $(TOP)/rules.mk