summaryrefslogtreecommitdiffstats
path: root/make.mk
diff options
context:
space:
mode:
authorJames Haggerty <james@gruemail.com>2022-10-25 09:24:54 +1100
committerJames Haggerty <james@gruemail.com>2022-10-25 09:24:54 +1100
commit07f439c598d585651871794a96c0d124f77a5d56 (patch)
treea7ca2b16c26b856ba05054c2b1fe8d6fabb6d551 /make.mk
parent5bd0aafc24afffe33d4a014bc9af9865f708a65b (diff)
downloadSensor-Watch-07f439c598d585651871794a96c0d124f77a5d56.tar.gz
Sensor-Watch-07f439c598d585651871794a96c0d124f77a5d56.tar.bz2
Sensor-Watch-07f439c598d585651871794a96c0d124f77a5d56.zip
Fix Linux Makefile parallelism
Makefile != bourne shell, I think. At least on my systems, this was causing a raw -j, which meant that make had no restriction on its parallelism (i.e. tried to build everything at once).
Diffstat (limited to 'make.mk')
-rw-r--r--make.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/make.mk b/make.mk
index 25401642..2fe89d75 100644
--- a/make.mk
+++ b/make.mk
@@ -31,7 +31,7 @@ else
endif
ifeq ($(DETECTED_OS), LINUX)
- MAKEFLAGS += -j `nproc`
+ MAKEFLAGS += -j $(shell nproc)
endif
ifeq ($(DETECTED_OS), OSX)
NPROCS = $(shell sysctl hw.ncpu | grep -o '[0-9]\+')