summaryrefslogtreecommitdiffstats
path: root/make.mk
diff options
context:
space:
mode:
authorWesley Ellis <tahnok@gmail.com>2022-07-14 14:42:32 -0400
committerWesley Ellis <tahnok@gmail.com>2022-07-14 14:42:32 -0400
commit6f96e848c233abd39e12e15bcf1cd32f48331894 (patch)
treec759942dcbffaa5d093c903600a85a61c3b01144 /make.mk
parent87da5f15ea314d53d97cee5f9fd13b4f83455256 (diff)
downloadSensor-Watch-6f96e848c233abd39e12e15bcf1cd32f48331894.tar.gz
Sensor-Watch-6f96e848c233abd39e12e15bcf1cd32f48331894.tar.bz2
Sensor-Watch-6f96e848c233abd39e12e15bcf1cd32f48331894.zip
Replace python with python3 for calling uf2conv
Instead of calling python use python3. On a default debian 11 install there is no python binary, only python3. Given that the uf2conv script is written for python 3 I think this is a safe change to make
Diffstat (limited to 'make.mk')
-rw-r--r--make.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/make.mk b/make.mk
index d8e2bf8a..dacce3fa 100644
--- a/make.mk
+++ b/make.mk
@@ -45,7 +45,7 @@ ifndef EMSCRIPTEN
CC = arm-none-eabi-gcc
OBJCOPY = arm-none-eabi-objcopy
SIZE = arm-none-eabi-size
-UF2 = python $(TOP)/utils/uf2conv.py
+UF2 = python3 $(TOP)/utils/uf2conv.py
CFLAGS += -W -Wall -Wextra -Wmissing-prototypes -Wmissing-declarations
CFLAGS += --std=gnu99 -Os