summaryrefslogtreecommitdiffstats
path: root/make.mk
diff options
context:
space:
mode:
authorJoey Castillo <joeycastillo@utexas.edu>2022-01-26 21:32:55 -0500
committerJoey Castillo <joeycastillo@utexas.edu>2022-01-26 21:33:05 -0500
commita11275d84c4ca04645eec72b1d1612d0781e0486 (patch)
treea091cb481317cf26e22f0aa9fa0c9b70a5626ed3 /make.mk
parent1b1bba2de0f23cec2de21100b495d56c1056af72 (diff)
downloadSensor-Watch-a11275d84c4ca04645eec72b1d1612d0781e0486.tar.gz
Sensor-Watch-a11275d84c4ca04645eec72b1d1612d0781e0486.tar.bz2
Sensor-Watch-a11275d84c4ca04645eec72b1d1612d0781e0486.zip
watch library: implement SPI
Diffstat (limited to 'make.mk')
-rw-r--r--make.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/make.mk b/make.mk
index 11b87c71..47170963 100644
--- a/make.mk
+++ b/make.mk
@@ -85,6 +85,7 @@ SRCS += \
$(TOP)/watch-library/hardware/watch/watch_adc.c \
$(TOP)/watch-library/hardware/watch/watch_gpio.c \
$(TOP)/watch-library/hardware/watch/watch_i2c.c \
+ $(TOP)/watch-library/hardware/watch/watch_spi.c \
$(TOP)/watch-library/hardware/watch/watch_uart.c \
$(TOP)/watch-library/hardware/watch/watch_deepsleep.c \
$(TOP)/watch-library/hardware/watch/watch_private.c \
@@ -152,6 +153,7 @@ SRCS += \
$(TOP)/watch-library/simulator/watch/watch_adc.c \
$(TOP)/watch-library/simulator/watch/watch_gpio.c \
$(TOP)/watch-library/simulator/watch/watch_i2c.c \
+ $(TOP)/watch-library/simulator/watch/watch_spi.c \
$(TOP)/watch-library/simulator/watch/watch_uart.c \
$(TOP)/watch-library/simulator/watch/watch_deepsleep.c \
$(TOP)/watch-library/simulator/watch/watch_private.c \