summaryrefslogtreecommitdiffstats
path: root/make.mk
diff options
context:
space:
mode:
authorJames Haggerty <james@gruemail.com>2022-11-02 06:18:23 +1100
committerJames Haggerty <james@gruemail.com>2022-11-02 06:18:34 +1100
commitad6e919107fb0bb38d01b1ed6e7ca1b56f9719ed (patch)
tree027905b85ba3ae004c983412db59df80ed683db4 /make.mk
parentb7a461d280d06749aeb14af1e8c17cbf3616055b (diff)
downloadSensor-Watch-ad6e919107fb0bb38d01b1ed6e7ca1b56f9719ed.tar.gz
Sensor-Watch-ad6e919107fb0bb38d01b1ed6e7ca1b56f9719ed.tar.bz2
Sensor-Watch-ad6e919107fb0bb38d01b1ed6e7ca1b56f9719ed.zip
Separate emscripten build directory
This avoids the need to 'make clean' before you do a simulator build (or vice-versa).
Diffstat (limited to 'make.mk')
-rw-r--r--make.mk4
1 files changed, 4 insertions, 0 deletions
diff --git a/make.mk b/make.mk
index 2fe89d75..446ad6fe 100644
--- a/make.mk
+++ b/make.mk
@@ -1,5 +1,9 @@
##############################################################################
+ifndef EMSCRIPTEN
BUILD = ./build
+else
+BUILD = ./build-sim
+endif
BIN = watch
ifndef BOARD