summaryrefslogtreecommitdiffstats
path: root/make.mk
diff options
context:
space:
mode:
authorJoey Castillo <joeycastillo@utexas.edu>2022-05-06 17:06:27 -0400
committerJoey Castillo <joeycastillo@utexas.edu>2022-05-06 17:12:14 -0400
commitd4ebe64af05e2fa163bcea0dd699ae9c8934cc6f (patch)
tree0f9db98200a7fc0028ef2549ddfba15918b7465d /make.mk
parent21026c8eb750b35c07bb3ae9fb043fd01e502a06 (diff)
downloadSensor-Watch-d4ebe64af05e2fa163bcea0dd699ae9c8934cc6f.tar.gz
Sensor-Watch-d4ebe64af05e2fa163bcea0dd699ae9c8934cc6f.tar.bz2
Sensor-Watch-d4ebe64af05e2fa163bcea0dd699ae9c8934cc6f.zip
add support for a small filesystem on the watch
Diffstat (limited to 'make.mk')
-rw-r--r--make.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/make.mk b/make.mk
index ac5be775..07c69337 100644
--- a/make.mk
+++ b/make.mk
@@ -87,6 +87,7 @@ SRCS += \
$(TOP)/watch-library/hardware/watch/watch_i2c.c \
$(TOP)/watch-library/hardware/watch/watch_spi.c \
$(TOP)/watch-library/hardware/watch/watch_uart.c \
+ $(TOP)/watch-library/hardware/watch/watch_storage.c \
$(TOP)/watch-library/hardware/watch/watch_deepsleep.c \
$(TOP)/watch-library/hardware/watch/watch_private.c \
$(TOP)/watch-library/hardware/watch/watch.c \
@@ -158,6 +159,7 @@ SRCS += \
$(TOP)/watch-library/simulator/watch/watch_i2c.c \
$(TOP)/watch-library/simulator/watch/watch_spi.c \
$(TOP)/watch-library/simulator/watch/watch_uart.c \
+ $(TOP)/watch-library/simulator/watch/watch_storage.c \
$(TOP)/watch-library/simulator/watch/watch_deepsleep.c \
$(TOP)/watch-library/simulator/watch/watch_private.c \
$(TOP)/watch-library/simulator/watch/watch.c \