summaryrefslogtreecommitdiffstats
path: root/make.mk
diff options
context:
space:
mode:
authorJoey Castillo <joeycastillo@utexas.edu>2021-12-21 10:05:40 -0600
committerJoey Castillo <joeycastillo@utexas.edu>2021-12-21 10:05:40 -0600
commit4862472d1d8b9ea0bb8888965500f7372b4c5bfe (patch)
tree6f85d110163f7ea58f254aac7c649fc93d8eba1a /make.mk
parent6256e709bf0e29444f6d5383897bc77acd242529 (diff)
parentb903c9665f0d975c60e248f6fb1c2cab0273d452 (diff)
downloadSensor-Watch-4862472d1d8b9ea0bb8888965500f7372b4c5bfe.tar.gz
Sensor-Watch-4862472d1d8b9ea0bb8888965500f7372b4c5bfe.tar.bz2
Sensor-Watch-4862472d1d8b9ea0bb8888965500f7372b4c5bfe.zip
Merge branch 'main' of github.com:joeycastillo/Sensor-Watch into main
Diffstat (limited to 'make.mk')
-rw-r--r--make.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/make.mk b/make.mk
index f6a37c7e..f1301733 100644
--- a/make.mk
+++ b/make.mk
@@ -20,7 +20,8 @@ else
MKDIR = mkdir
endif
-CFLAGS += -W -Wall --std=gnu99 -Os
+CFLAGS += -W -Wall -Wextra -Wmissing-prototypes -Wmissing-declarations
+CFLAGS += --std=gnu99 -Os
CFLAGS += -fno-diagnostics-show-caret
CFLAGS += -fdata-sections -ffunction-sections
CFLAGS += -funsigned-char -funsigned-bitfields