summaryrefslogtreecommitdiffstats
path: root/make.mk
diff options
context:
space:
mode:
authorGeorge Hahn <George.Hahn.VHS@gmail.com>2022-05-29 20:30:02 -0600
committerGitHub <noreply@github.com>2022-05-29 22:30:02 -0400
commita4fc6204ce27a4fcce071515ee9e5757818b4af5 (patch)
treea3549820fdb7a9c7345883519c36f4b59b986dad /make.mk
parent6ed757af2b7778e6944a5a8761672bc8d03620e2 (diff)
downloadSensor-Watch-a4fc6204ce27a4fcce071515ee9e5757818b4af5.tar.gz
Sensor-Watch-a4fc6204ce27a4fcce071515ee9e5757818b4af5.tar.bz2
Sensor-Watch-a4fc6204ce27a4fcce071515ee9e5757818b4af5.zip
Parallelize alternate fw builds (#66)
Diffstat (limited to 'make.mk')
-rw-r--r--make.mk26
1 files changed, 26 insertions, 0 deletions
diff --git a/make.mk b/make.mk
index ac5be775..d8e2bf8a 100644
--- a/make.mk
+++ b/make.mk
@@ -9,12 +9,38 @@ endif
##############################################################################
.PHONY: all directory clean size
+# OS detection, adapted from https://gist.github.com/sighingnow/deee806603ec9274fd47
+DETECTED_OS :=
+ifeq ($(OS),Windows_NT)
+ DETECTED_OS = WINDOWS
+else
+ UNAME_S := $(shell uname -s)
+ ifeq ($(UNAME_S),Linux)
+ DETECTED_OS = LINUX
+ endif
+ ifeq ($(UNAME_S),Darwin)
+ DETECTED_OS = OSX
+ endif
+endif
+$(if ${VERBOSE},$(info OS detected: $(DETECTED_OS)))
+
ifeq ($(OS), Windows_NT)
MKDIR = gmkdir
else
MKDIR = mkdir
endif
+ifeq ($(DETECTED_OS), LINUX)
+ MAKEFLAGS += -j `nproc`
+endif
+ifeq ($(DETECTED_OS), OSX)
+ NPROCS = $(shell sysctl hw.ncpu | grep -o '[0-9]\+')
+ MAKEFLAGS += -j $(NPROCS)
+endif
+ifeq ($(DETECTED_OS), WINDOWS)
+ MAKEFLAGS += -j $(NUMBER_OF_PROCESSORS)
+endif
+
ifndef EMSCRIPTEN
CC = arm-none-eabi-gcc
OBJCOPY = arm-none-eabi-objcopy