summaryrefslogtreecommitdiffstats
path: root/movement/make/Makefile
diff options
context:
space:
mode:
authorWesley Ellis <tahnok@gmail.com>2021-11-22 21:20:57 -0500
committerWesley Ellis <tahnok@gmail.com>2021-11-22 21:37:21 -0500
commitb7ed9adb6c41089da75d258d7148fa87d2f76d20 (patch)
tree6cfe28b0652d193d46e36590cd831db68fc8fb85 /movement/make/Makefile
parent7817e6696e438c8af74342ef10b576975a0e5448 (diff)
downloadSensor-Watch-b7ed9adb6c41089da75d258d7148fa87d2f76d20.tar.gz
Sensor-Watch-b7ed9adb6c41089da75d258d7148fa87d2f76d20.tar.bz2
Sensor-Watch-b7ed9adb6c41089da75d258d7148fa87d2f76d20.zip
Add initial TOTP watch face impl
Vendor code from https://github.com/Netthaw/TOTP-MCU to do the heavy lifting of computing SHA-1 and HMAC and the rest of TOTP Also implement a date_time to unix timestamp method
Diffstat (limited to 'movement/make/Makefile')
-rwxr-xr-xmovement/make/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/movement/make/Makefile b/movement/make/Makefile
index b595d2dd..4c895322 100755
--- a/movement/make/Makefile
+++ b/movement/make/Makefile
@@ -16,6 +16,7 @@ INCLUDES += \
-I../watch_faces/complications/ \
-I../watch_faces/thermistor/ \
-I../watch_faces/demos/ \
+ -I../lib/TOTP-MCU/ \
# If you add any other source files you wish to compile, add them after ../app.c
# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
@@ -24,6 +25,8 @@ INCLUDES += \
# ../drivers/lis2dh.c \
# ../watch_faces/fitness/step_count_face.c
SRCS += \
+ ../lib/TOTP-MCU/sha1.c \
+ ../lib/TOTP-MCU/TOTP.c \
../movement.c \
../watch_faces/clock/simple_clock_face.c \
../watch_faces/settings/preferences_face.c \
@@ -37,6 +40,7 @@ SRCS += \
../watch_faces/complications/beats_face.c \
../watch_faces/complications/day_one_face.c \
../watch_faces/complications/stopwatch_face.c \
+ ../watch_faces/complications/totp_face.c \
# Leave this line at the bottom of the file; it has all the targets for making your project.
include $(TOP)/rules.mk