summaryrefslogtreecommitdiffstats
path: root/movement/make/Makefile
diff options
context:
space:
mode:
authorJoey Castillo <joeycastillo@utexas.edu>2022-05-09 12:14:42 -0400
committerJoey Castillo <joeycastillo@utexas.edu>2022-05-09 12:14:42 -0400
commit21ee056e26c3e158cf56f8577169f86b8d577a65 (patch)
tree12d2841a2d2ccd33eb1fbb73f7f1ad990d1cd140 /movement/make/Makefile
parent91b436237aaf39e2328b9380042aa40e06faa4cb (diff)
downloadSensor-Watch-21ee056e26c3e158cf56f8577169f86b8d577a65.tar.gz
Sensor-Watch-21ee056e26c3e158cf56f8577169f86b8d577a65.tar.bz2
Sensor-Watch-21ee056e26c3e158cf56f8577169f86b8d577a65.zip
first pass at filesystem in movement
Diffstat (limited to 'movement/make/Makefile')
-rwxr-xr-xmovement/make/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/movement/make/Makefile b/movement/make/Makefile
index 0936a26c..1c880fc2 100755
--- a/movement/make/Makefile
+++ b/movement/make/Makefile
@@ -16,6 +16,7 @@ INCLUDES += \
-I../watch_faces/complication/ \
-I../watch_faces/sensor/ \
-I../watch_faces/demo/ \
+ -I../../littlefs/ \
-I../lib/TOTP-MCU/ \
-I../lib/sunriset/ \
-I../lib/vsop87/ \
@@ -33,7 +34,10 @@ SRCS += \
../lib/sunriset/sunriset.c \
../lib/vsop87/vsop87a_milli.c \
../lib/astrolib/astrolib.c \
+ ../../littlefs/lfs.c \
+ ../../littlefs/lfs_util.c \
../movement.c \
+ ../filesystem.c \
../watch_faces/clock/simple_clock_face.c \
../watch_faces/clock/world_clock_face.c \
../watch_faces/clock/beats_face.c \