summaryrefslogtreecommitdiffstats
path: root/movement/make/Makefile
diff options
context:
space:
mode:
authorJoey Castillo <joeycastillo@utexas.edu>2022-04-06 14:56:18 -0400
committerJoey Castillo <joeycastillo@utexas.edu>2022-04-06 14:56:18 -0400
commit4e89d70f999c8766a9cebe0700e1d6ea9d7bbfcf (patch)
tree2baca9564649801aef3be5dc4600284900d528d6 /movement/make/Makefile
parent2cba47996ed08c83b7c9b2ba521b68fb8a62f666 (diff)
parent1ec1f2e4207405d55c34c936e2c458cb4a7e8806 (diff)
downloadSensor-Watch-4e89d70f999c8766a9cebe0700e1d6ea9d7bbfcf.tar.gz
Sensor-Watch-4e89d70f999c8766a9cebe0700e1d6ea9d7bbfcf.tar.bz2
Sensor-Watch-4e89d70f999c8766a9cebe0700e1d6ea9d7bbfcf.zip
Merge branch 'main' of github.com:joeycastillo/Sensor-Watch into mars-clock
Diffstat (limited to 'movement/make/Makefile')
-rwxr-xr-xmovement/make/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/movement/make/Makefile b/movement/make/Makefile
index 415bc152..2516cc44 100755
--- a/movement/make/Makefile
+++ b/movement/make/Makefile
@@ -18,6 +18,8 @@ INCLUDES += \
-I../watch_faces/demo/ \
-I../lib/TOTP-MCU/ \
-I../lib/sunriset/ \
+ -I../lib/vsop87/ \
+ -I../lib/astrolib/ \
# If you add any other source files you wish to compile, add them after ../app.c
# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
@@ -29,6 +31,8 @@ SRCS += \
../lib/TOTP-MCU/sha1.c \
../lib/TOTP-MCU/TOTP.c \
../lib/sunriset/sunriset.c \
+ ../lib/vsop87/vsop87a_milli.c \
+ ../lib/astrolib/astrolib.c \
../movement.c \
../watch_faces/clock/simple_clock_face.c \
../watch_faces/clock/world_clock_face.c \
@@ -37,6 +41,7 @@ SRCS += \
../watch_faces/settings/set_time_face.c \
../watch_faces/sensor/thermistor_readout_face.c \
../watch_faces/sensor/thermistor_logging_face.c \
+ ../watch_faces/sensor/thermistor_testing_face.c \
../watch_faces/demo/character_set_face.c \
../watch_faces/demo/voltage_face.c \
../watch_faces/demo/lis2dh_logging_face.c \
@@ -51,6 +56,9 @@ SRCS += \
../watch_faces/complication/blinky_face.c \
../watch_faces/complication/moon_phase_face.c \
../watch_faces/clock/mars_time_face.c \
+ ../watch_faces/complication/orrery_face.c \
+ ../watch_faces/complication/astronomy_face.c \
+ ../watch_faces/complication/tomato_face.c \
# New watch faces go above this line.
# Leave this line at the bottom of the file; it has all the targets for making your project.