summaryrefslogtreecommitdiffstats
path: root/movement/make/Makefile
diff options
context:
space:
mode:
authorjoeycastillo <joeycastillo@utexas.edu>2021-10-18 15:37:41 -0400
committerGitHub <noreply@github.com>2021-10-18 15:37:41 -0400
commit6210e1c233a3ee66274389e85889b0681102378d (patch)
treeec94a012f533e8f7017223648321c46c3c9796f4 /movement/make/Makefile
parent84c0fbfa2a68dc3c29b989947567d111e70a037b (diff)
parent32710098577c982123d9391132165c0b02a57482 (diff)
downloadSensor-Watch-6210e1c233a3ee66274389e85889b0681102378d.tar.gz
Sensor-Watch-6210e1c233a3ee66274389e85889b0681102378d.tar.bz2
Sensor-Watch-6210e1c233a3ee66274389e85889b0681102378d.zip
Merge pull request #17 from joeycastillo/wip-launcher
Resolves #13
Diffstat (limited to 'movement/make/Makefile')
-rwxr-xr-xmovement/make/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/movement/make/Makefile b/movement/make/Makefile
new file mode 100755
index 00000000..f17fc7e5
--- /dev/null
+++ b/movement/make/Makefile
@@ -0,0 +1,32 @@
+# Leave this line at the top of the file; it has all the watch library sources and includes.
+TOP = ../..
+include $(TOP)/make.mk
+
+# If you add any other subdirectories with header files you wish to include, add them after ../
+# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
+# INCLUDES += \
+# -I../ \
+# -I../drivers/ \
+# -I../watch_faces/fitness/
+INCLUDES += \
+ -I../ \
+ -I../watch_faces/ \
+ -I../watch_faces/clock/ \
+ -I../watch_faces/settings/ \
+ -I../watch_faces/complications/ \
+
+# If you add any other source files you wish to compile, add them after ../app.c
+# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
+# SRCS += \
+# ../movement.c \
+# ../drivers/lis2dh.c \
+# ../watch_faces/fitness/step_count_face.c
+SRCS += \
+ ../movement.c \
+ ../watch_faces/clock/simple_clock_face.c \
+ ../watch_faces/settings/preferences_face.c \
+ ../watch_faces/settings/set_time_face.c \
+ ../watch_faces/complications/pulsometer_face.c \
+
+# Leave this line at the bottom of the file; it has all the targets for making your project.
+include $(TOP)/rules.mk