summaryrefslogtreecommitdiffstats
path: root/movement/make/Makefile
diff options
context:
space:
mode:
authorJoey Castillo <jose.castillo@gmail.com>2021-10-16 12:58:14 -0400
committerJoey Castillo <jose.castillo@gmail.com>2021-10-16 12:58:14 -0400
commite8461984d60a80841a5f4b219358cc20567114f8 (patch)
treef81b719dd66a821b129f2809798caee39ea9451a /movement/make/Makefile
parent9d4367565b20ef9d42f793fc00daa575c46b0e3c (diff)
downloadSensor-Watch-e8461984d60a80841a5f4b219358cc20567114f8.tar.gz
Sensor-Watch-e8461984d60a80841a5f4b219358cc20567114f8.tar.bz2
Sensor-Watch-e8461984d60a80841a5f4b219358cc20567114f8.zip
launcher is now movement
Diffstat (limited to 'movement/make/Makefile')
-rwxr-xr-xmovement/make/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/movement/make/Makefile b/movement/make/Makefile
new file mode 100755
index 00000000..35b80079
--- /dev/null
+++ b/movement/make/Makefile
@@ -0,0 +1,32 @@
+# Leave this line at the top of the file; it has all the watch library sources and includes.
+TOP = ../..
+include $(TOP)/make.mk
+
+# If you add any other subdirectories with header files you wish to include, add them after ../
+# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
+# INCLUDES += \
+# -I../ \
+# -I../drivers/ \
+# -I../widgets/fitness/
+INCLUDES += \
+ -I../ \
+ -I../widgets/ \
+ -I../widgets/clock/ \
+ -I../widgets/settings/ \
+ -I../widgets/complications/ \
+
+# If you add any other source files you wish to compile, add them after ../app.c
+# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
+# SRCS += \
+# ../movement.c \
+# ../drivers/lis2dh.c \
+# ../widgets/fitness/step_count_widget.c
+SRCS += \
+ ../movement.c \
+ ../widgets/clock/simple_clock_widget.c \
+ ../widgets/settings/preferences_widget.c \
+ ../widgets/settings/set_time_widget.c \
+ ../widgets/complications/pulseometer_widget.c \
+
+# Leave this line at the bottom of the file; it has all the targets for making your project.
+include $(TOP)/rules.mk