summaryrefslogtreecommitdiffstats
path: root/movement/make
diff options
context:
space:
mode:
authorChristian Chapman <1360262+enthdegree@users.noreply.github.com>2023-01-20 20:15:28 -0500
committerGitHub <noreply@github.com>2023-01-20 19:15:28 -0600
commit027e3bb42ed0f0e0f6c2bacbc0c896d721e7cd63 (patch)
treed0e144ddffe1ce31c25dd192d815296fd0974781 /movement/make
parent7ef2d6541ad74f6eee96fbc89f2bc8d004d33ed0 (diff)
downloadSensor-Watch-027e3bb42ed0f0e0f6c2bacbc0c896d721e7cd63.tar.gz
Sensor-Watch-027e3bb42ed0f0e0f6c2bacbc0c896d721e7cd63.tar.bz2
Sensor-Watch-027e3bb42ed0f0e0f6c2bacbc0c896d721e7cd63.zip
Morse-code based RPN calculator (#164)
* Added Morse code based RPN calculator * added manual and memory register * fixed morsecalc negative indicator, edited header comment * adjusted stack display controls * Fixed warnings. Added calculator token aliasing ability. Added binary shorthand for numeral entry. Extended morse code binary tree. * ui tweaks * Update movement_config.h * silence warning Co-authored-by: Christian Chapman <user@debian> Co-authored-by: joeycastillo <joeycastillo@utexas.edu>
Diffstat (limited to 'movement/make')
-rw-r--r--movement/make/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/movement/make/Makefile b/movement/make/Makefile
index 374c04be..fa43a5e9 100644
--- a/movement/make/Makefile
+++ b/movement/make/Makefile
@@ -22,6 +22,7 @@ INCLUDES += \
-I../lib/sunriset/ \
-I../lib/vsop87/ \
-I../lib/astrolib/ \
+ -I../lib/morsecalc/ \
# If you add any other source files you wish to compile, add them after ../app.c
# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
@@ -38,6 +39,10 @@ SRCS += \
../lib/sunriset/sunriset.c \
../lib/vsop87/vsop87a_milli.c \
../lib/astrolib/astrolib.c \
+ ../lib/morsecalc/calc.c \
+ ../lib/morsecalc/calc_fns.c \
+ ../lib/morsecalc/calc_strtof.c \
+ ../lib/morsecalc/mc.c \
../../littlefs/lfs.c \
../../littlefs/lfs_util.c \
../movement.c \
@@ -88,6 +93,7 @@ SRCS += \
../watch_faces/complication/tempchart_face.c \
../watch_faces/complication/tally_face.c \
../watch_faces/complication/tarot_face.c \
+ ../watch_faces/complication/morsecalc_face.c \
../watch_faces/complication/rpn_calculator_face.c \
# New watch faces go above this line.