summaryrefslogtreecommitdiffstats
path: root/movement/make
diff options
context:
space:
mode:
authorJames Haggerty <james@gruemail.com>2023-01-11 08:15:00 +1100
committerGitHub <noreply@github.com>2023-01-10 16:15:00 -0500
commit529bad306d94624cb2eefbfd16b17fc9fd7e4773 (patch)
tree7c44591ea8fe8db42bf382616875df6735ea25c3 /movement/make
parent0aa77e27e4149fac6def8c8d86b00d9b47cf857a (diff)
downloadSensor-Watch-529bad306d94624cb2eefbfd16b17fc9fd7e4773.tar.gz
Sensor-Watch-529bad306d94624cb2eefbfd16b17fc9fd7e4773.tar.bz2
Sensor-Watch-529bad306d94624cb2eefbfd16b17fc9fd7e4773.zip
RPN Calculator face (#112)
* Calculator face with guess a number * Add more functions, cleanup, and blinking * Display operations better in the first location * Clean up stack behaviour Add empty stack behaviour, check stack bounds, add stack operations. Also, make 'mode' always work to switch through faces on entering calculator (i.e. by defaulting to OPERATION rather than NUMBER). Some edge cases. * Tweak negative rounding behaviour; add basic doco * Add copyright name. * Flip ordering of binary operations * Fix compiler warnings * Remove watch_private_display hackery and give face a better name Also, slightly clearer documentation and a dupe function.
Diffstat (limited to 'movement/make')
-rw-r--r--movement/make/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/movement/make/Makefile b/movement/make/Makefile
index 60084594..9def50de 100644
--- a/movement/make/Makefile
+++ b/movement/make/Makefile
@@ -75,6 +75,7 @@ SRCS += \
../watch_faces/demo/frequency_correction_face.c \
../watch_faces/complication/alarm_face.c \
../watch_faces/complication/ratemeter_face.c \
+ ../watch_faces/complication/rpn_calculator_alt_face.c \
# New watch faces go above this line.
# Leave this line at the bottom of the file; it has all the targets for making your project.