summaryrefslogtreecommitdiffstats
path: root/movement/make
diff options
context:
space:
mode:
authorEmilienCourt <emilien.court@telecomnancy.net>2023-01-14 17:58:03 +0100
committerGitHub <noreply@github.com>2023-01-14 11:58:03 -0500
commit9ebea46300bd1bc4e3ba51b1c7915e3ba42c471a (patch)
tree013dfc56976b23c31e5501c9cc31f8ca0aa1c2c2 /movement/make
parent2e618850702bc9a55b1a530c89ab928c2d09501c (diff)
downloadSensor-Watch-9ebea46300bd1bc4e3ba51b1c7915e3ba42c471a.tar.gz
Sensor-Watch-9ebea46300bd1bc4e3ba51b1c7915e3ba42c471a.tar.bz2
Sensor-Watch-9ebea46300bd1bc4e3ba51b1c7915e3ba42c471a.zip
totp : rework and add SHA256/512 (#151)
* totp : rework and add SHA256/512 * totp : comment code * totp : fix SHA224/SHA384 and examples * totp : fix bug in totp_face_lfs * totp : init_totp_record to SHA1 * totp : move TOTP-MCU to TOTP, update README and example * totp : SHAX, use size_t n instead of harcoded 8 * clarify what to put in TOTP face Co-authored-by: Emilien <Emilien> Co-authored-by: joeycastillo <joeycastillo@utexas.edu>
Diffstat (limited to 'movement/make')
-rw-r--r--movement/make/Makefile8
1 files changed, 5 insertions, 3 deletions
diff --git a/movement/make/Makefile b/movement/make/Makefile
index a8b7f4b8..374c04be 100644
--- a/movement/make/Makefile
+++ b/movement/make/Makefile
@@ -17,7 +17,7 @@ INCLUDES += \
-I../watch_faces/sensor/ \
-I../watch_faces/demo/ \
-I../../littlefs/ \
- -I../lib/TOTP-MCU/ \
+ -I../lib/TOTP/ \
-I../lib/base32/ \
-I../lib/sunriset/ \
-I../lib/vsop87/ \
@@ -30,8 +30,10 @@ INCLUDES += \
# ../drivers/lis2dh.c \
# ../watch_faces/fitness/step_count_face.c
SRCS += \
- ../lib/TOTP-MCU/sha1.c \
- ../lib/TOTP-MCU/TOTP.c \
+ ../lib/TOTP/sha1.c \
+ ../lib/TOTP/sha256.c \
+ ../lib/TOTP/sha512.c \
+ ../lib/TOTP/TOTP.c \
../lib/base32/base32.c \
../lib/sunriset/sunriset.c \
../lib/vsop87/vsop87a_milli.c \