summaryrefslogtreecommitdiffstats
path: root/movement/make
diff options
context:
space:
mode:
authorTheOnePerson <a.nebinger@web.de>2023-01-11 21:31:53 +0100
committerGitHub <noreply@github.com>2023-01-11 15:31:53 -0500
commitb28d31ba03c90aebc9d3c57ae0df6fc18c60f826 (patch)
tree5181785a0d55087319f5592c1aa6615a8d2e0741 /movement/make
parent47812f462d275ff62e3796d4064cdac66772f6c9 (diff)
downloadSensor-Watch-b28d31ba03c90aebc9d3c57ae0df6fc18c60f826.tar.gz
Sensor-Watch-b28d31ba03c90aebc9d3c57ae0df6fc18c60f826.tar.bz2
Sensor-Watch-b28d31ba03c90aebc9d3c57ae0df6fc18c60f826.zip
Interval timers face (#130)
* buzzer sequences: first draft, does not work on hardware yet (but in simulator) * buzzer sequences: add changes to movement.c * buzzer sequences: add demo face to Makefile * buzzer sequences: fix problem of interrupted sounds. Add logic for repeating sub sequences. Tidy up (move logic to watch_buzzer files, remove buzzer_demo_face) * buzzer sequences: tidy up even more * buzzer sequences: disable registering a 32 Hz tick callback for watch faces, so it will be used exclusively by the buzzer sequences functionality * buzzer sequences: add callback slot functionality to watch_rtc and make watch_buzzer use it. Switch internal buzzer sequences tick frequency to 64 Hz. Revert changes to movement.c * interval face: add initial version * interval face: fix theoretical problem in helper function * buzzer sequences: fix parameter sanity check in watch_rtc code * buzzer sequences/watch_rtc: optimize calling tick callbacks in RTC_Handler * buzzer sequences/watch_rtc: fix error in calling callback functions * buzzer sequences: revert changes to watch_rtc logic. Instead, use TC3 as the source for timing the sound sequences. * buzzer sequences: fix frequency of callback * buzzer sequences: integrate changes from PR #162 (set both CCBUF and PERFBUF for correct buzzer tone) Co-authored-by: joeycastillo <joeycastillo@utexas.edu>
Diffstat (limited to 'movement/make')
-rw-r--r--movement/make/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/movement/make/Makefile b/movement/make/Makefile
index 48d985f4..1ecb7c28 100644
--- a/movement/make/Makefile
+++ b/movement/make/Makefile
@@ -76,6 +76,7 @@ SRCS += \
../watch_faces/demo/frequency_correction_face.c \
../watch_faces/complication/alarm_face.c \
../watch_faces/complication/ratemeter_face.c \
+ ../watch_faces/complication/interval_face.c \
../watch_faces/complication/rpn_calculator_alt_face.c \
../watch_faces/complication/stock_stopwatch_face.c \
../watch_faces/complication/tachymeter_face.c \