summaryrefslogtreecommitdiffstats
path: root/movement/make
diff options
context:
space:
mode:
authorJames Haggerty <james@gruemail.com>2022-11-01 17:08:05 +1100
committerGitHub <noreply@github.com>2022-11-01 01:08:05 -0500
commitb7a461d280d06749aeb14af1e8c17cbf3616055b (patch)
tree899fb8f3b9aefbbbcddc969f0e6d04570adc7661 /movement/make
parent54495d2d295675da636c60d864715ea36e8ebedd (diff)
downloadSensor-Watch-b7a461d280d06749aeb14af1e8c17cbf3616055b.tar.gz
Sensor-Watch-b7a461d280d06749aeb14af1e8c17cbf3616055b.tar.bz2
Sensor-Watch-b7a461d280d06749aeb14af1e8c17cbf3616055b.zip
Make the TOTP face use the filesystem for secret storage (#95)
* TOTP using filesystem * Filesystem: ability to read files line by line
Diffstat (limited to 'movement/make')
-rw-r--r--movement/make/Makefile3
1 files changed, 3 insertions, 0 deletions
diff --git a/movement/make/Makefile b/movement/make/Makefile
index f0f26c3f..bf9351eb 100644
--- a/movement/make/Makefile
+++ b/movement/make/Makefile
@@ -18,6 +18,7 @@ INCLUDES += \
-I../watch_faces/demo/ \
-I../../littlefs/ \
-I../lib/TOTP-MCU/ \
+ -I../lib/base32/ \
-I../lib/sunriset/ \
-I../lib/vsop87/ \
-I../lib/astrolib/ \
@@ -31,6 +32,7 @@ INCLUDES += \
SRCS += \
../lib/TOTP-MCU/sha1.c \
../lib/TOTP-MCU/TOTP.c \
+ ../lib/base32/base32.c \
../lib/sunriset/sunriset.c \
../lib/vsop87/vsop87a_milli.c \
../lib/astrolib/astrolib.c \
@@ -55,6 +57,7 @@ SRCS += \
../watch_faces/complication/day_one_face.c \
../watch_faces/complication/stopwatch_face.c \
../watch_faces/complication/totp_face.c \
+ ../watch_faces/complication/totp_face_lfs.c \
../watch_faces/complication/sunrise_sunset_face.c \
../watch_faces/complication/countdown_face.c \
../watch_faces/complication/counter_face.c \