summaryrefslogtreecommitdiffstats
path: root/movement/make
diff options
context:
space:
mode:
authorTheOnePerson <a.nebinger@web.de>2023-01-10 22:31:32 +0100
committerGitHub <noreply@github.com>2023-01-10 16:31:32 -0500
commitd0a3fd23778fec57c6010c0ee04d038a0bae34e4 (patch)
tree26f15527a251ffc55723a5c987879a041f51cd80 /movement/make
parent529bad306d94624cb2eefbfd16b17fc9fd7e4773 (diff)
downloadSensor-Watch-d0a3fd23778fec57c6010c0ee04d038a0bae34e4.tar.gz
Sensor-Watch-d0a3fd23778fec57c6010c0ee04d038a0bae34e4.tar.bz2
Sensor-Watch-d0a3fd23778fec57c6010c0ee04d038a0bae34e4.zip
Add stock stopwatch face (#140)
* buzzer sequences: first draft, does not work on hardware yet (but in simulator) * buzzer sequences: add changes to movement.c * buzzer sequences: add demo face to Makefile * buzzer sequences: fix problem of interrupted sounds. Add logic for repeating sub sequences. Tidy up (move logic to watch_buzzer files, remove buzzer_demo_face) * buzzer sequences: tidy up even more * buzzer sequences: disable registering a 32 Hz tick callback for watch faces, so it will be used exclusively by the buzzer sequences functionality * buzzer sequences: add callback slot functionality to watch_rtc and make watch_buzzer use it. Switch internal buzzer sequences tick frequency to 64 Hz. Revert changes to movement.c * buzzer sequences: fix parameter sanity check in watch_rtc code * stock stopwatch: first fully functional implementation * stock stopwatch: fix typo in comment * stock stopwatch: handle resuming from deep sleep mode properly * buzzer sequences/watch_rtc: optimize calling tick callbacks in RTC_Handler * buzzer sequences/watch_rtc: fix error in calling callback functions * stock stopwatch: implement workaround for sleep mode * stock stopwatch: merge current main into stock-stopwatch * stock stopwatch: use TC counters as source for callbacks * stock-stopwatch: revert unnecessary changes to watch_buzzer Co-authored-by: joeycastillo <joeycastillo@utexas.edu>
Diffstat (limited to 'movement/make')
-rw-r--r--movement/make/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/movement/make/Makefile b/movement/make/Makefile
index 9def50de..40f798c6 100644
--- a/movement/make/Makefile
+++ b/movement/make/Makefile
@@ -76,6 +76,7 @@ SRCS += \
../watch_faces/complication/alarm_face.c \
../watch_faces/complication/ratemeter_face.c \
../watch_faces/complication/rpn_calculator_alt_face.c \
+ ../watch_faces/complication/stock_stopwatch_face.c \
# New watch faces go above this line.
# Leave this line at the bottom of the file; it has all the targets for making your project.