summaryrefslogtreecommitdiffstats
path: root/movement/make
diff options
context:
space:
mode:
authorRaymundo Cassani <raymundo.cassani@gmail.com>2023-01-10 16:43:04 -0500
committerGitHub <noreply@github.com>2023-01-10 16:43:04 -0500
commitfee6145e4d79a0d67d7e390692152bfdf94676a3 (patch)
tree13bdef350168d6699741f8abcfab3a8c3d8d4773 /movement/make
parent18de75be5a1391c00b772a669b3583b8567fa194 (diff)
downloadSensor-Watch-fee6145e4d79a0d67d7e390692152bfdf94676a3.tar.gz
Sensor-Watch-fee6145e4d79a0d67d7e390692152bfdf94676a3.tar.bz2
Sensor-Watch-fee6145e4d79a0d67d7e390692152bfdf94676a3.zip
Add Tachymeter face (#165)
* Create template for tachymeter * Basic working tachymeter * Improve UI for running and results * Allow editing distance * Alarm long-press to enter and exit editing mode * Improve light button behaviour * Set distance digit wise. * Use 250ms resolution for total time * Improve comments * Bugfix: Show distance when running and face becomes active * Update `%d` to `%lu` in `sprintf` call for `uint32_t` * Ignore Alarm button (Up and Long-press) when showing results * Improve GUI when running and face gets activated * Change speed indicator from `/H` to `/h` * silence warnings in tachymeter face Co-authored-by: joeycastillo <joeycastillo@utexas.edu>
Diffstat (limited to 'movement/make')
-rw-r--r--movement/make/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/movement/make/Makefile b/movement/make/Makefile
index 40f798c6..0e2a313a 100644
--- a/movement/make/Makefile
+++ b/movement/make/Makefile
@@ -77,6 +77,7 @@ SRCS += \
../watch_faces/complication/ratemeter_face.c \
../watch_faces/complication/rpn_calculator_alt_face.c \
../watch_faces/complication/stock_stopwatch_face.c \
+ ../watch_faces/complication/tachymeter_face.c \
# New watch faces go above this line.
# Leave this line at the bottom of the file; it has all the targets for making your project.