summaryrefslogtreecommitdiffstats
path: root/movement/make
diff options
context:
space:
mode:
authorjoeycastillo <joeycastillo@utexas.edu>2022-03-04 14:52:49 -0600
committerGitHub <noreply@github.com>2022-03-04 14:52:49 -0600
commitccdf08da876d2c66bbc54cc246443676c4f9bf2e (patch)
tree77473da9df40f9b1f7cec5f8bd03c1b52c26b8e7 /movement/make
parentea988208e10dbcf62eff65522ec9f92231d880e9 (diff)
downloadSensor-Watch-ccdf08da876d2c66bbc54cc246443676c4f9bf2e.tar.gz
Sensor-Watch-ccdf08da876d2c66bbc54cc246443676c4f9bf2e.tar.bz2
Sensor-Watch-ccdf08da876d2c66bbc54cc246443676c4f9bf2e.zip
Movement: Astronomy and Orrery watch faces (#55)
Diffstat (limited to 'movement/make')
-rwxr-xr-xmovement/make/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/movement/make/Makefile b/movement/make/Makefile
index 9231d5ce..cd4471b5 100755
--- a/movement/make/Makefile
+++ b/movement/make/Makefile
@@ -18,6 +18,8 @@ INCLUDES += \
-I../watch_faces/demo/ \
-I../lib/TOTP-MCU/ \
-I../lib/sunriset/ \
+ -I../lib/vsop87/ \
+ -I../lib/astrolib/ \
# If you add any other source files you wish to compile, add them after ../app.c
# Note that you will need to add a backslash at the end of any line you wish to continue, i.e.
@@ -29,6 +31,8 @@ SRCS += \
../lib/TOTP-MCU/sha1.c \
../lib/TOTP-MCU/TOTP.c \
../lib/sunriset/sunriset.c \
+ ../lib/vsop87/vsop87a_milli.c \
+ ../lib/astrolib/astrolib.c \
../movement.c \
../watch_faces/clock/simple_clock_face.c \
../watch_faces/clock/world_clock_face.c \
@@ -50,6 +54,8 @@ SRCS += \
../watch_faces/complication/countdown_face.c \
../watch_faces/complication/blinky_face.c \
../watch_faces/complication/moon_phase_face.c \
+ ../watch_faces/complication/orrery_face.c \
+ ../watch_faces/complication/astronomy_face.c \
# New watch faces go above this line.
# Leave this line at the bottom of the file; it has all the targets for making your project.